SOLVED: Upgrade to RW8 and now Addons not showing in Library


(Jeroen Born) #1

I just upgraded to RW8 and now I cannot see my Addons / Themes / Stacks. I had also the Foundation package. My last projects were all built on RW6. Should I use this to continue with my project?


(Neil) #2

Did you use this upgrade guide? https://help.realmacsoftware.com/en/articles/2201707-upgrading-from-rapidweaver-7-or-earlier


(Paul Dennison) #5

Your previous version of RW should still be there, upgrading to RW8 doesn’t delete it.

Same for your stacks, they will still be there where the old version of RW put them, you might have to import them into RW8. There might well be a button for it (not at home to be able to check).


(Jeroen Born) #6

I managed to copy my Addons and put them in a new folder. These are now showing in RW8 in the Preferences, but when I open a project, it doesn’t display them in my Library… thus the project ‘thinks’ it needs Stacks, but I have these already…


Any suggestions?


(Paul Dennison) #7

Will have a proper look later once I’m home


(Joe Workman) #8

Did you restart RW after making the change? If you hit cmd+7 in RW. Does the correct adding folder show in Finder? Are the stacks there?


(Jeroen Born) #9

Yes, it is showing the new folder, but not coming up in the Library. See screenshots above.


(Paul Dennison) #10

Notice that you have the “Buy Stacks” ribbon in your screenshot.

Which version of Stacks are you using and has it got it’s serial number correctly entered? May that is contributing to the problem?


(Jeroen Born) #11

Shouldn’t it show ALL what is showing in the Addons preferences? The Library is now virtually empty, only the standard RW addons. That is why the red ribbon look, unfortunately. You would expect that RW8 is somewhat more intelligent? I’ve restarted iMac, no change. Renamed the folder (no spaces). But no change.


(Paul Dennison) #12

What version fo RW and Stacks did you have previously?

Probably Stacks should show what you expect but it shouldn’t be showing the option to purchase the Stacks plugin if it was working correctly and installed.

Maybe back to first principles?

  1. Remove/delete the Stacks plugin (Reveal the Add-on folder in Finder)
  2. restart RW8
  3. reinstall the Stacks plugin, ideally latest version you have, either 3.5 or 4
  4. restart RW8
  5. check stacks is working/no banner to buy
  6. Use RW8 to open the stacks folder in finder
  7. Close RW8
  8. transfer your stacks back OR restart RW8 and point Stacks to the folder you have them saved.

(Jan Fuellemann) #13

Tagging @isaiah


(Paul Dennison) #14

@Fuellemann Knew I forgot to add that step :sunglasses:


(Jeroen Born) #15

[quote=“pmjd, post:12, topic:28705”]
What version fo RW and Stacks did you have previously?
[/quote] That was/is RW 6.4 and Stacks 3.6.8.


(Jeroen Born) #16

Hi, I am not a developer, just an RW user. What is ‘tagging’ in this case?


(Jan Fuellemann) #17

Sorry - it means just telling the Stacks developer to tune in and help.


(Jeroen Born) #18

I am just confused. Why are all the addons/themes/stacks visible in the folder/preferences, but RW8 just does not want to reveal them in the Library? Never had this issue/bug with RW6 or previous versions. It has costs me a full day, and still it is not solved no matter what I try… and with the intention of the good people/users of this RW forum. Even tried starting a new project to see if every purchase in the past is available. Nothing, nada, noppes, nunca.


(Paul Dennison) #19

Afraid I can’t give you a technical reason as I’m just a user as well.

Can you go back to RW6 and if you can is everything working there still? If you tried to open RW6 files in RW8 they will have been converted, so make sure to try and older RW6 file to check.

Not sure why the upgrade hasn’t gone too well. Could be a case of reinstalling RW8 then Stacks plugin but unfortunately I don’t know all the additional places to delete files from to make it a fresh install that will hopefully be trouble free.

Hopefully Isaiah will be able to advise you better and get Stacks working


(Jeroen Born) #20

Hi Paul, in RW6 all my Addons like Stacks and Themes are still there and the projects work just fine.

Copied all the Addons to a new folder for RW8, as instructed on the RW8 support page. All is visible in the preferences, but NOT in the Library.
Maybe it is because I don’t have Stacks 4, but an older version 3.6.?
Then I ask myself do you need Stacks 4 to run RW8?
And do third party stacks made for older versions RW7-RW5 no longer work in RW8?
But, this week upgraded also Cart2 to Cart 3 and this is compatible with RW8 it says on the product page, and so was expecting that this Stack would show up in the Library, but also not.

CAN THE DEVELOPERS PLEASE STEP IN AND HELP?
Am I missing perhaps a hidden file that is necessary?

Just a user question: If you can see a stack in your preferences, how can you get it in your Library so that you can drop it in a stack?


(scott williams) #21

I would conact support fir Yourhead.com the maker of the Stacks plugin.


(Jeroen Born) #22

Latest attempt: I now let RW arrange the Addons. The result is the same: I can see all the Addons in the Preferences, but again NOT in the LIBRARY.

How have all the Users, Pro’s, Wizkids, Developers dealt with this?
How can you instruct RW8 to show ALL my Addons? I now feel I upgraded for a Ferrari without an engine…

Isn’t this a major BUG?