My stacks are gone! But they are installed!?

I’m running the latest version of RapidWeaver 8, and suddenly I don’t see almost any of my stacks! I have a LOT and they are ALL in the correct place - BUT - hardly any appear in the list like they did before. I’ve removed them all, added them back one at a time, but only some of them appear in the stacks list. I’ve also reinstalled the application, and even tried changing the location to a folder I created and put a set of stacks into - still nada! This is killing me, as I need to update a site but all of the stacks I’ve used come up with candy cane stripes saying they aren’t installed! HELP!!!

Have you set the add ons folder to be “Managed by RapidWeaver”?

Not sure what else you need to do to trigger this, best to @ realmac support

1 Like

Yes. Everything as default. They just went poof!

If I double click on one to reinstall it - I get the regular dialog box that asks me to restart RapidWeaver, but the stack doesn’t show up in the list. Out of say sixty odd stacks, about 20 are visible. No matter how many times I reinstall them. I’m stumped.


you can see that the names of the stacks are missing - but the checkboxes are there!?

the stacks plugin installed itself in the add-on folder - I tried removing it and placing it in the stacks folder to see if that made a difference and it didn’t. You can see I have a bunch of stacks, but none are appearing in the app.

If you press Reveal in Finder, which folder is then opened? The one you see currently?

Can you drag and drop the stacks on your RW icon? Make sure you select the right version of RW you drag the icons onto.

I’ve seen this happen a couple times before. I’m not really sure what causes it, but for whatever reason the folder that RW believes is the addons folder is not really the folder that is getting used.

The folder that Stacks looks in for installed 3rd party stacks is always the folder right next to itself. In fact, it can’t be any other folder, Stacks only has access to that folder now that the app is sandboxed.

So I think the thing to do here is to ask Stacks itself, where it is looking. You can do that by clicking the gear menu at the bottom of the Stacks Library and choosing Show Stacks Library in Finder from the popup menu.


At this point I think we’ll have one of two different scenarios – and I’d give them even odds:

  1. Some other folder
    It may be that this is some other folder – perhaps in a different and more well hidden area of the hidden Library folder and this folder has exactly the items that are currently in your Stacks Library. If that’s the case, then you can simply drag the stacks from where-ever they are installed now into this new place, restart RapidWeaver and you should be good to go.
    And, after getting your critical publish on its way make sure to report back here where this hidden folder actually is. It might help us understand how this situation came to pass.

  2. It’s the same folder
    It may be that the folder that RW thinks is your addons folder opens right up. And there all your stacks are, but for some strange reason Stacks just can’t seem to see them. If this is the case then the problem is that the macOS sandbox, for whatever reason, has decided not to give access to RapidWeaver to the Stacks folder.
    The easiest way to get over that hurdle is to move the location of the addons folder back to the default: (in the RapidWeaver Preferences) set to “Managed by RapidWeaver”

If you don’t have a custom location set – then set one. Then choose Managed by RapidWeaver afterwards (probably restarting RapidWeaver each time).

The location that is “managed by RapidWeaver” is inside of the “Sandbox Container” – so has no macOS sandbox restrictions at all! We are free to do whatever we like in there! Yeah!

So, now… Open up Stacks and use the gear menu to Open up the Stacks Library folder (just like the screenshot in #1 above). This folder should be deep inside of the Library folder and in a place where the sandbox gives RapidWeaver complete freedom.

The folder path (in Mojave) should be something like:

HardDisk/Users/your_user_name/Library/Group Containers/

The Hard Disk, your user name, and the long string of random characters will be unique to you. In different versions of macOS and different versions of RapidWeaver it’s a bit different.

You should now be able to drag your stacks into this folder and (after a restart of RapidWeaver) they should appear as normal.

There is a remote chance that it’s neither of these two cases. And if that happens, please let us know what you find, and as many details as you can. I may try to assist you a bit more via email and with the help of your project file too. But hopefully it won’t come to that. :slight_smile: Good luck!



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.