RW Classic Update location?

Update error RW
despite my best efforts, updating the RW Classic automatically is still impossible for me. When I press “check for updates” I get the “update error” window.
@dang I have followed your instructions to the letter - deleted everything, and installed it again, but to no avail.
The version I have now is 9.2.1 (21062). Is there a newer update, and if so how do I go about it?

Hi @Karmela_Faktor,

That error means you haven’t moved the RapidWeaver application from the folder you downloaded it to, to your Applications folder.

Move the app to your Applications folder and then try running the update, it should work then.

If that doesn’t work let us know.

I’ve tried again Dan, followed your instructions, and again it’s not working.
After the latest download, I ended up with the older version 9.1.1(21049), but no way to update it.

Double check it’s running from your Applications folder, and then it’s probably worth restarting your Mac to clear out any Gremlins!

I repeated the whole process once more (deleted the old download, and downloaded RWC again into the Application folder). Now I’ve got the version 9.2.1 (21062)
Made sure this is the only version.
Restarted my Mac.
Still - when trying to check for updates I get the “Update Error!” window.

Do you have any content blockers or VPN running that might be blocking the connection to our update server?

Also try testing by changing your internet connection to a different one and trying again. For example if you are using your home internet, can you disconnect and try connecting to your mobile 4G/5G connection and see if the update is working from there?

No content blockers except Ghostery for Safari.
I will try changing the internet connection, but the fact is - until the update to RWC there was never an issue with automatic updates.
Will keep you updated.
Thank you for the assistance.

Understood, it’s just that the only time we see that error you posted in your screenshot is when people forget to move RapidWeaver to their Applications folder. Other than that we don’t see it.

We haven’t had any other person report that they cannot clear that error when they move the app to their Applications folder, so this issue wouldn’t be with RapidWeaver Classic, but with something funky going on on your Mac or network connection.

If you still see the error after trying a different internet connection, feel free to DM me and we can schedule a Zoom call so I can try and troubleshoot this in real-time for you.


@dang, it took a while, during which time I tried everything, deleting and reinstalling RW in my Applications folder, changing the internet connection, to reinstalling macOS via macOS Recovery. I have even changed the modem for a new model. Yet still, the attempt to update RWC gives the same “Update Error” msg. So far - I could always update from the direct link on the RW website, hope that will be the case in the future as well, just need to know when the new update is available.

Yep, the latest versions can always be downloaded from the release notes page. And announcements are made in the Announcements forum, so if you subscribe to notifications there you’ll be notified when new updates are released.

Also I’m still available for a one-on-one session if you want to try and troubleshoot in real-time. Feel free to DM me if you’d like to give it a try sometime.

1 Like

I’ve had this problem and it’s because the RapidWeaver app has been translocated during the installation. I’m not going to attempt to explain this but there is an easy solution. Move the app from the Applications folder into a different folder - I used my downloads folder. Then run RapidWeaver from the new location and try to update it. It it runs the update process without error you’ll be OK and you can then move it back to the applications folder.

1 Like

Thank you so much @allygill for the tip, sounds interesting and good.
I will sure give it a try. Hope it works just as well for me.

1 Like