RW Install and Relaunch never works


(Bonnie Tessler) #1

I have had this issue going back to maybe RW 5. It’s never gone away. Now it’s here (still) with 7.5.1 and I finally want it fixed!

The problem is that the automatic update just NEVER works for me. I always have to download the trial version and use that to update the software. Not the most horrible problem, just annoying.

Here’s what happens: whenever I click the Install Update button, the update downloads and extracts - so far everything is totally normal. Then I click on Install and Relaunch - and nothing. RW closes and that’s it. It never updates, it never re-launches, nothing happens. And when I finally manually re-open the program, I get the same “An update is available!” notice except I’m just not as excited anymore - so I say Remind me Later…

Does anyone have any thoughts about why the auto-update is not working?

Thanks,

Bonnie


(Kenneth Wilkinson) #2

Yep, hasn’t worked for me for years…

I post a similar description to yours on the forums when I get irritated; then download the application from Realmac and upgrade that way.

Not a huge problem, just never fails to annoy me.


(NeilUK) #3

I might be stating the obvious here, but have you made sure that “Check for Updates” is selected in RW’s preferences?


(Gary) #4

@NeilUK It is the actual installation of the update that never works.

Unfortunately, this is just how RW works (or doesn’t work) in my experience. Seems to work for some and doesn’t install correctly for others.


(Jannis from inStacks Software) #5

That is not a RW problem, but a macOS problem in general. For me, the RW update worked always, but I am not able to update 1Password. In that case, I have to download 1Password installer and update from there.

Maybe the issue disappears when deleting the whole app once and reinstall it again, but that is just a guess.


(Bonnie Tessler) #6

@instacks Unfortunately I have tried to delete the whole app and reinstall (that approach was suggested to me by Realmac a couple of years ago, I think) but it didn’t help.

Well, it helps (a little) to know that I am not alone.

Thanks!


(Greg Schneck) #7

The “install and relaunch” of plugins and stacks fails for me many times also. I don’t even try it any more. I download, quit RW, manually drop the add-on into the appropriate folder and then relaunch. Of course, an app update is a bit different. I wonder… after the install and you are asked to relaunch… what would happen if you killed the app, restarted OSX, and then launched the update?


(Rob D) #8

Jannis, if this is OS issue rather than RW, how do you explain the fact that ALL apps except RW update automatically without a slightest problem (at least on my computer)?

This is not limited to updating. If I ever have ANY problem whatsoever, surely, none of dozens of apps I use is involved but RapidWeaver. Go, figure…


(Jannis from inStacks Software) #9

How do you explain that all apps on my first MacBook are updating automatically (including RW), but not 1Password?

And further more, on my second MacBook, all apps are updating normally, including RW and 1Password?

It’s just not that easy to blame the one app which doesn’t behave correctly.


(Brian LaPan) #10

I’ve had the same issue with RapidWeaver myself for a couple of years. The auto update runs and the app quit and then nothing. If I restarted RapidWeaver again, then it repeated the need for the update. I did run this by the boys in Brighton and we spent a lot of time trying to fix it. When I created a new user account and loaded RapidWeaver, it worked every time. So, it had to be something in my user acct. perhaps something, somewhere deep in some preferences that we couldn’t isolate. I decided to (like many others) just download the latest release when the update notice came up and replace the old copy with the new.

Then, and I don’t guarantee this’ll work for anybody else, yesterday when I downloaded the latest Stacks release (beta) and restarted RapidWeaver, that notice once again came up and I thought I’d try the auto update and it WORKED. First time in 2+ years and I have no idea why. And, I’m still on Sierra, too. YMMV


(Bonnie Tessler) #11

@LaPan Well that’s encouraging! I think I downloaded the latest version and THEN updated Stacks. So I will be able to try your theory with 7.5.2 whenever that is.

@1611mac I’m not sure if that could work. I think once you restart, the install and relaunch button would disappear and you would have to open RW fresh again - and have to start from the update announcement again. But it’s worth a try.

Thanks for the suggestions - and commiseration!


(Greg Schneck) #12

I meant to let it install and then shutdown/launch when you get the “Relaunch” dialog but perhaps my memory is wrong and you don’t have that opportunity. (I download and install complete apps - not updates for me.) I do know that when installing add-ons you are asked to quit or relaunch - but perhaps not with app updates. Apologies if I steered you wrong… just ideas…