RW Version 7.1 not loading stacks 3.1


(Brian Vince) #1

I have just upgraded to 7.1 (from 7.0) and it says "Stacks 3.1.0 is incompatible with RapidWeaver 7.1"
Anyone else had this problem?
If you haven’t upgraded yet you might like to wait till this issue has been resolved?


(Gary Wann) #2

You beat me to it!

Clicking on ‘Update Plugins’ does nothing.

Reinstalled stacks 3.1.0_2980 and get a warning message ‘This plugin is already installed’ or similar, installed it again anyway, but still get the incompatible stack message.

Can’t load any of my stacks sites now - gulp!


#3

Are you both using a beta of 7.1? I am not seeing this update and thought it was a few weeks from being complete.


(Gary Wann) #4

I didn’t notice anything in the update notes to say it was a beta, but I’ve elected to receive the beta updates and the version number ends with ‘b’ so I guess the answer is ‘Yes’

At least it will get me away from the keyboard for a little while after 2 days of non-stop web authoring!


(Mathew Mitchell) #5

Yes, it looks like this is a beta. Unfortunately RM did not “label” it as beta. (BTW this is really not a good thing to do.) I had “elect to receive betas” on. When I saw this thread I turned off that option, restarted RW, and then got no repeat message about 7.1. Thus … I’m assuming it’s a beta release.


#6

I had the option for betas disabled and it wasn’t visible. When I enabled it just now 7.1 was suddenly available, but as mentioned above not shown as a beta. It would seem wise for these beta updates to be shown as such with appropriate warnings, but I guess you can always delete RW and go back to the previous version.


(Brian Vince) #7

I do have Beta updates enabled, but the Upgrade notice didn’t say beta … I don’t think. :frowning:


(Brian Vince) #8

Yep, delete and back to previous version it is … I had beta releases turned on because the early versions of 7 had issues in exporting, for me, so I needed the most recent upgrades. Normally I would have it turned off. Having said that I wouldn’t have expected something as fundamental as a stacks incompatibility to get to beta release in any case.


#9

If you feel like living on the edge the beta of 7.1 appears to work if you also update Stacks to the latest beta Stacks 3.1.1 Beta Release


(Gary Wann) #10

Darksky, how did you go about reverting to the previous version?

I don’t want to loose all my ‘extras’ and I tried restoring the previous version of the app executable from Time Machine as a copy and that didn’t want to run.


(Brian Vince) #11

Beta stack too? Maybe tomorrow. :wink:

I haven’t reverted yet, but I was going to just pick up the old zip dowload and install that …


(Gary Wann) #12

Thanks, I’ll just hang fire and await events before I start messing around with versions. I’ve come to a natural breakpoint fortunately, now working on a web forum that doesn’t require RW.

Can’t wait for the next RW Podcast :smile:


(Brian Vince) #13

I am successfully back to RW 7.0.4 :slight_smile: I notice that even with the beta updates turned on I am not now seeing the 7.1 update. :slight_smile:


(Gary Wann) #14

Yep, me too - was easier than I thought. Renamed the beta app with a ‘b’ on the end. Downloaded the last ‘trial’ zip from the Realmac site and dropped the app into Applications.

Up and running with 7.0.4 again :slight_smile:

And yes, no updates being shown as available, maybe it shouldn’t have beed released just yet?


(Mathew Mitchell) #15

Someone at RealMac probably noted the initial problems and pulled 7.1. That’s a good thing.

But this also indicates they are pretty far along with developing 7.1 and it seems it will have a number of important enhancements and fixes. Looking forward to the final 7.1 whenever it arrives. I was expecting Sept/Oct, but it seems like it will be sometime in August.


(Brian Vince) #16

Not tempted to try the “beta pairing”, @Mathew? I think I will if 7.1 beta pops up again … see what enhancements and fixes are there …


(Mathew Mitchell) #17

@Darksky Tempted? Yes. But I’m now at a critical juncture with 2 websites that are a lot of work. So I need to be conservative in my “behaviors” for the next 4 weeks. After that I can be more adventurous again. :slight_smile:


(Brian Vince) #18

@Mathew, I know that feeling. I am currently in maintenance mode, so not quite so critical for me atm. I will post my experience, if I get the time to trial it. :slight_smile:


(Simon Maddox) #19

Hi guys,

First of all, if you don’t want to receive beta releases of RapidWeaver that may break your site or stop it from opening, then make sure that “Check for Beta Updates” is turned off. If you’re going to turn it on, always make sure you have a backup of your project that you can revert to at any moment. As @dan’s mum always used to say: a careful weaver is a happy weaver!

With that said, we did release a 7.1 beta update this morning. No, it wasn’t pulled.

If you’ve downloaded the beta and want to go back to the current public release, you can find downloads for each version on the RapidWeaver Release Notes page.

Hope that helps!


(Gary Wann) #20

Interesting, if the beta wasn’t pulled, I wonder why it’s no longer showing up as an update? I’m more than happy testing beta software, but something as basic as not being compatible with the latest version of stacks is a bit of a show-stopper is it not?

One of the reasons I went with the update was because it said that it fixed the problem with siteloc pages not being previewed. I’ve just ditched Lockdown due to lack of development and long page generation times during upload and I’ve spent a couple of days configuring siteloc. Not being able to preview the pages isn’t a great problem, you can deleted the code snippet to see the rest of the page and then paste it back in before uploading.

Simon, it’s all well and good backing up the project in case of corruption, but not a lot of help if the RW app itself won’t display the project due to not working with stacks!