RW6 "damaged"—Waaaa?


(Kathleen Meyer) #1

Dialog box says it wont open and to put it in trash. How do I download it again? Before or after deleting damaged one? Will I lose everything I built in it?


(Doug Bennett) #2

Never seen that dialogue box before. You can download a new copy here

https://kb.realmacsoftware.com/article/38-rapidweaver-6-x-x-release-notes

I would try reinstalling without deleting first.


(Kathleen Meyer) #3

Ahhhh, thanks big-time! Dummy that I am, I managed to do it and drag it into my Applications folder. And then to dump the old version off my dock. I seem to be able to open all the existing Web site files from the Menu bar, but NOT from the icons conveniently sitting on my desktop. I should probably dump them, too? Imagine they’re connected with the damaged version?


(Lisa Sandler) #4

Anytime you download a new version, you should get rid of any aliases on your desktop or in the dock and replace them with the new application :slight_smile:


(Doug Bennett) #5

I assuming that the one in the application folder works? If so then yes move the desktop version to your trash can. If you want a copy on your desktop the in finder open you application folder find RapidWeaver and hold command+option and drag to desktop. This will create an alias to the working version.


(Kathleen Meyer) #6

OK, I trashed all the old ones on the desktop, which wiped out all but one in the “Open Recent” Menu, which freaked me out. But then I was able to get those back from RW5, which several are still published from. Those that made it back into RW6 and onto the desktop have a purple icon. And I can open them fine. The one that was still there has a stacks icon, and when I try to move it to the desktop, I get a purple icon with a black arrow, AND a dialog box that says Something Went Wrong.

Now I’m going to try to open one of the sites in Safari, hoping I can get back to this chat page.


(Kathleen Meyer) #7

Yep, everything seems fine on the Web.


(Kathleen Meyer) #8

I still can’t get it onto the desktop, but it’s not lost. Thanks so verrrry much! I’m signing off.


(Lisa Sandler) #9

To get a copy/alias of the program/application on the desktop, select it, choose “file” > “make alias”, then drag the alias to the desktop. This you can do with any application or file on a Mac.


(Kathleen Meyer) #10

Thanks, but I don’t have a “make alias” in the “file” menu. Doing what teefers suggested—holding down common+option and dragging it to desktop—worked with all the others. This one doesn’t. And I’ve started all over again, pitching out all copies and trying to create a new file in RW6 from the original in RW5. It comes over with a stacks icon (that won’t open) rather than the regular purple. What is sooo bothersome is it’s my most active site (always adding and subtracting stuff) and I’d like to rebuild and published it in RW6.

Skipping to RW7 would be lovely, but my computer won’t support the operating system.


(Lisa Sandler) #11

What OS are you using?


(Kathleen Meyer) #12

OS X 10.9.5
I have a make alias, but not in RW. Seems like it has to be on the desktop to make an alias.

I just cleared the project window, and then tried again to bring the problem file from RW5 to RW6. Something must go wrong in the upgrade. I’ve now sent off a “report” on one of the Error dialog boxes.


(Lisa Sandler) #13

In the OP, you were referring to the icon of the application on the desktop, so yes, that is how you make an alias of the program on the desktop. An alias is not a copy. It’s a way to access a program or a file from the desktop or dock.
Not sure what you’re trying to do with an alias in RW program itself. You seem to be talking about a few things now.


(Doug Bennett) #14

I’m not sure what you are trying to do either. Your title to this thread says RW 6 damaged. You should only have one copy of the program for rw6 in your application folder. You can setup alias on the dock or desktop or both.

Now if you go to applications folder and click on RapidWeaver does it launch ok?

Is the “problem file” a project file from RapidWeaver?
If that was what you were having problems with to begin with than both Lisa and I didn’t understand.
If the project file that was on the desktop was what was damaged then redownloading RW would not have helped.
If that is the case you would need to recover a backup copy from time machine or other backup.


(Kathleen Meyer) #15

teefers, you helped me install a new RW6, which WAS damaged. And then I trashed the damaged one. But that left RW6 empty. So I began moving things into it from RW5. Everything moved fine—that is, “created upgrade”—except for one file of a Web site.

To be clear, I’m not trying to make aliases of the RW6 program. In fact, I’m not trying to make aliases of anything. I now have all the files (they don’t say alias) conveniently on my desktop, except the problem one. When I open it in RW5, it “creates upgrade” in RW6 and puts an icon on my desktop. When I try to open it, I get “Something Went Wrong.”

Same thing happens when I try to open it from “Recently Opened.” And yet, it WILL open from the projects window. (And finally, somewhere in the last six go-rounds I’ve eliminated the stacks icons.)


(Lisa Sandler) #16

You’ve got to distinguish what it is you are doing in RW, vs the desktop. RW6 empty? A folder? Your file? Moving things into it… again, in RW or the desktop folders?


(Kathleen Meyer) #17

Sorry, I’m lacking in terminology. When I opened the newly installed RW6 there were no project files in it. To me, it was empty, nothing to work from. If I can remember now, when I, then, opened each file I’d built in RW5, it created an upgrade and dropped it into the Projects Window in the newly installed RW6. Then teefers told me how to get them from there onto the desktop, by holding command+option. Everything followed along fine except the one problem Web site file that’s being a pain. And I would just forget about it, and plan on opening it from the Projects Window, but it’s making me nervous!


(Kathleen Meyer) #18

I have to make a run to the store. Will check back later.

All your time is very much appreciated.


(Lisa Sandler) #19

You can always open a RW file from where it lives on your computer by double clicking on it. It shouldn’t matter where you open it from, except in the “recent” files it might show you older files so unless you know for sure what it is, I’d open from the hard drive.

It’s possible the one website has a bad or old add-on or stack… can you still open it in RW5?


(Kathleen Meyer) #20

Yes, can still open in RW5. And it’s OK on the Web. sweetsagemt.com

But I can’t easily rebuild in RW6. All the others came over intact but for the banners which need to be reinstalled.