RW7 & Stacks 3.0. Formatting issues


(John) #1

Just upgraded to RW7. All seemed to go smoothly and all ok. Have tried editing a plain text stack, and I’m unable to format the text. Even if I try to enter html code, it still doesn’t format the text. I am using Stacks 3.0. I am using the offload theme that came with RW7


(Isaiah Carew) #2

When you say you “unable to format the text” does this mean that the formatting buttons in the bottom toolbar are grayed out? Or that you’ve used them and they seem to have no effect?

The HTML stack is for plain-text – which means no-formatting. You can, of course, use HTML to format text – but you cannot apply formatting to your HTML.


(John) #3

I used a text stack. Just a simple task like putting a carriage return in, look ok when entered, but on publishing all the text was in a single line. It also removed the space after a full stop.


(Brian LaPan) #4

Stacks is now at 3.1 btw. Maybe update it?


(Scott Steven) #5

The issue is stacks I think, I have had the same issues in 3.1 Stacks pages won’t let me change things in some of the stack areas. I have had to delete data and re add it and it works for a while until the next time I go to make an edit. Just a bit buggy.


(Isaiah Carew) #7

I think this issue (and also @scottsteven’s) need a bit more in-depth info than I can get here on the forum. Do you think you could share a copy of your file(s) with our support folks at support@yourhead.com

Just put the simplest thing that demonstrates the bug into a the simplest page – if you can do it with a default theme and without 3rd party stacks it helps get right to the issue a lot faster.

Isaiah


(Scott Steven) #8

I will see what I can do to replicate this otherwise I will do a screen cast and share it with support. this is not a consistent issue it seems to move around. It seems to pop up on the longer pages that scroll on. I am building some online owners manuals for radiology software and some of the pages are a bit long and thats where the issue pops up, FYI I am using UiKit and the related stacks latest stacks and RW 7


(Isaiah Carew) #9

@scottsteven – i think the original posters issue is quite different since it occurs on even simple pages – and yours seems to happen mostly on larger pages

i strive to stay on topic – but i’ll just post this one quick thing…

Only appearing on larger pages is a good clue – in 95% of the cases I see like that it has to do with the content on the page – when that content throwing off the RapidWeaver styled text engine things can get strange. One of the common causes is pasting in content from other pages or other apps.

I wrote this about similar problems previously:
http://cafe.yourhead.com/?qa=47/why-does-text-copied-from-other-apps-look-strange&show=48#a48

If that doesn’t help, then by all means, please contact support with as much info as you have.

Also: I’m sorry to say a movie is rarely helpful. It only helps in you convincing me that the problem exists – and since I’m already connived - I really do believe you :stuck_out_tongue: – it’s not much help. To be able to help I need to see the a file that shows the problem so that I can look at the inner workings of the file in a debugger and find out what is really going on. A movie just doesn’t provide that kind of detail. But, if that’s all you’ve got – then I’ll take it – beggars can’t be choosers. :wink:

Isaiah


(Scott Steven) #10

Noted thanks for the input I will have a look. Its not a business stopper