Text stack turns into links after latest update (RESOLVED)


(Rocio Evenett) #1

I noticed that after the last update to Text stack, it’s harder to keep content as rich text…
First noticed this with a partial stack consisting of several text lines which I have to go back and manually convert into text

I’ve now come to expect that every time the Text stack is used, I’ll have to spend time converting the text from links to rich or plain text

Anyone else having the same problem?


(Isaiah Carew) #2

Sorry you’re having issues. I’d like to know more about what you mean “'ll have to spend time converting the text from links to rich or plain text” – can you explain what you are doing there?

The built in Text stack is unchanged since the initial Stacks release in 2009. So I’m not sure which update you’re referring to but – but I think it’s a safe bet to say that it’s not due to an update of this stack. :stuck_out_tongue:

One common source issues is that content brought from other apps is not always compatible with RapidWeaver. This is actually a RapidWeaver behavior as a whole and not specific to Stacks. You can find more details here:
http://cafe.yourhead.com/?qa=47/why-does-text-copied-from-other-apps-look-strange&show=47#q47


(Rocio Evenett) #3

Hi Isaiah,

Thank you for pointing me to that link!
It all makes sense now…
I copied and pasted from Text pages created in a previous version of Rapid Weaver, and it mainly seems to happen in one page


(Isaiah Carew) #4

If you can provides some details about the problem. Or send a file to our support folks that contains the page in question I could probably provide more specific assistance. However I’m afraid without more details I’m probably going to send you off in the wrong directly.

Isaiah


(Rocio Evenett) #5

Hi Isaiah,
I believe my problem with the text stack coincided with a Rapid weaver update and the theme I was using at the time (Volante)

Since I switched to Corporation Theme by Yuzool I haven’t had that problem

Thank you for replying and sorry it took me so long!


(Kate Cutting) #6

Hi,

I’m sorry to comment on a resolved issue, but I am experiencing the same problem and don’t know how to fix it.

I am using Rapidweaver 6 and the Streamline theme. I don’t want to swap themes, but every time I try to drop in a text stack it is appearing as linked text and I can’t seem to get rid of the link. I have tried ‘unlink’ but it doesn’t show that there is even a link in place. I can’t get the text to appear as just plain text.

It started happening yesterday, and since then I have tried doing updates but nothing will make it go back to normal.

Does anyone have any ideas? Thank you.

(P.S. This is the first time I have used a support forum, so please excuse me if I’m going about it wrong.)


(DeFliGra) #7

Best way to TroubleShoot is to ‘go clean’ meaning removing everything else but – in this case – the stack that’s not behaving as expected.

See if you can replicate the problem:

Create a new RapidWeaver file (see note 1)
Create a Stacks page (if your using Stacks)
Add only the Stacks you’re testing (or two that are conflicting).

Test – evaluete – does the same thing happen?

If it does? Try to change the theme.
Test – evaluete – does the same thing happen?

Note 1: It’s important to use a new blank RapidWeaver document. A lot of things can hide in an old RapidWeaver document. Custom css for the RapidWeaver page. Custom css for the entire RapidWeaver file. Javascripts… other Stacks on the page.

Best | DeFligra | www.defligra.com
Mac’O’Holic | Stack’O’Holic | Web’O’Holic


(Isaiah Carew) #8

Hi Kate,

Usually when the page is having trouble rendering – it’s due to some other text or HTML on the page that’s causing trouble. The the original post I pointed the user toward an answer to helped him find his pasted text. I would recommend looking for something similar in your file: pasted text, pasted HTML, or some other content that might be causing trouble.

And do as @defligra suggests and try simplifying the page a bit (or a copy of it) to see if you can narrow down the problem and tease out the culprit.

Isaiah


(Kate Cutting) #9

Hi there Isaiah,

I’m sorry for the delay responding. I wanted to say a big thank you for your support. I think the problem was caused by some text I had copied and pasted from another version of my website that is currently online. I had to delete the Rapidweaver page that was affected, and basically start it again, but this time I made sure to convert any copied text into plain text first, before pasting it into my project. Touch wood, so far this has worked. I appreciate the help. Thank you so much.

Kate


(Kate Cutting) #10

Thank you for your help. Your advice was very good and will help me to avoid problems moving forwards.

Kind regards,

Kate