RW8 crashed when publishing


(Paul Hastings) #1

Hi. Just upgraded to RW Version 8.0.1 (20080). I am using the mountain theme. Rebuilt one site and it uploaded fine. So I thought I would change another to the new theme.
Did a rw test on logins and it said correct.
When attempting to publish RW8 crashes. I have contacted my hosting company and they confirmed all logins are correct. Any advice on how to get RW8 to publish my site?


(Tom Phillips) #2

Much the same for me. I upgraded to RW8 just a couple of days ago, and today needed to make the first updates to my web site under the new version.

All was fine, and very familiar, until I clicked the “Publish” button. I got a message “Publishing Your Web Site - 0 out of 0 Files Published”, and nothing seemed to be happening. After waiting fifteen minutes (used to take just a few seconds to update changes) I looked at the Force Quit screen on my iMac, to see whether it said RW was not responding. It didn’t, so I waited a bit longer. Still nothing except the same message.

In the end, I clicked the “Cancel Publish” button. I got a message to say my updates were being cancelled, but then everything hung there too. The Mac’s Force Quit screen showed nothing amiss, but in the end I had to Force Quit, because it was pretty clear nothing was going to happen, and I couldn’t close RW8 down any other way.

I went back in and had a look at my publish settings. They were all fine but my publishing password was shown as blank. I assume it hadn’t copied over from RW7 settings. I added it, tested it ok and then clicked “Publish”. This time everything worked. I saved the site, exited RW8 and then reopened, to have another go and see if this had solved the problem. I made one very small change to the site and clicked “Publish”.

I got the complete repeat experience described above. RW8 had not saved my publishing password. I added it again, tested it, and then everything worked again.

In RW7 and earlier, I never had to enter the password each time I wanted to publish an update to my site. Has RW8 changed to a default of not saving it, and if not, how do I save it? I can’t see any option to do this.

Thanks very much.

Tom


(Doug Bennett) #3

RapidWeaver stores the publishing password in keychain. Did it prompt you for permission for keychain access?


(Marian Wosnitza) #4

I upgraded to RW8. Updated my website. Everything looked great in Preview. Now, after finishing a week of work, I wanted to publish the updated website: CRASH, whatever upload speed I choose. Connection to provider is correct and test is fine. Now I sit in deep sh*t.
Can anyone help???


(Greg Schneck) #5

This won’t resolve the failing of the site publishing but you could export to local folder and upload via sftp/ftp. This would at least get your update online…

You could also use single page publishing (it also allows for group publishing of “child” pages along with the main page.) Right click the page in the left hand page pane and select Publish Page (and with “child pages” if you so desire.)


(Paul Hastings) #6

I have sympathy for RW development team. However, if the product does not work or has many glitches? What’s the point there are many very well tested and usable products out there other than Rapid Weaver?

Rapid Weaver is a great product. However, we must all remember that they just like Bill Gates, use us to test and refine there product.

They usually test with very skilled website guys who know their stuff inside and out. I wonder do they experiment with a newbie?

They us use to find the faults in there programme.
They I am sure to do lots of testing, but it is us who work out the real-life problems.


(system) #7

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.