RWML changes not shown in browser


(Henridevries) #1

Hi,

SInce a couple of weeks I’ve renewed my Rapidweaver set-up in order to be able to use the RWML stack, make my website Multilangual. Updated to Rapidweaver 8 and latest version of Stacks. Tried to meet all the requirements and after that set-up my Home page and one other page “(Social)Media” to be used with a Switch for different languages.

Doesn’t show in Firefox nor in Safari. No switch visible, no possibilty to change the language to English nor German: www.neilyoungtribute.nl

System: IMAC 2007 (bit old), Mac OS High Sierra 10.13.6.

Thank you for a reply!

Regards,
Henri de Vries
The Hague
Holland


(Rob D) #2

RWML is a very robust suite of stacks. I have zero problems with it. But it is not a simple stack that you can set up effortlessly on your first try.

I would suggest you get in touch with @willwood and give him more details of your setup.


(Will Woodgate) #3

The link http://www.neilyougtribute.nl/ does not work for me.

So we can conclude this issue is most likely the result of your domain name or web server not being configured correctly. Once that is resolved and you have a basic website published, you’ll be able to start using the RWML stacks.

Speak with your web hosting company, if you need technical support with getting your website working.


(Jason Bostick) #4

There’s just a typo in the URL (a missing ‘n’): http://www.neilyoungtribute.nl/ works fine for me


(Henridevries) #5

Thanks for your reply. Will suggested earlier to me to use the forum…


(Rob D) #6

Hi, Henri,

Have you checked out the video and the example on RWML’s product page? There is also a downloadable User Guide that you can reach from the same page.

If you still can not get it to work for you, please, give us some more details of your setup and maybe some screenshots of your RWML settings. Like I said, it’s a complex piece of software, so troubleshooting is complicated, too.


(Henridevries) #7

Hi Rob,

I did watch the video and in my previews everything works fine. It’s after I’ve uploaded the website that it doesn’t show in Firefox, nor in Safari.

As a new user I was only allowed to upload one picture…

I use Rapidweaver 8.1, Firefox 62.02, MAC OS High Sierra 10.13.6

Thanks!


(Henridevries) #8

And the actual outcome in Preview mode. English language selected.


(Rob D) #9

Are you sure you are using latest versions of your theme and RWML stacks?

Your method of switching languages is different than mine, so it’s a bit difficult for me to pinpoint the fault.

In your screenshot, you have the ‘Switch Type’ set to Option Select Menu. I use the Text Or Images method (see my screenshot). Maybe you could try that as well? In this case, you would have to place a button-switcher somewhere within your content.

RWML%20Switch


(Dos) #10

@Henridevries
I faced the same problem, all fine in preview but failing live.
I tried several settings for the site language but that didn’t solve the problem.
Then I used the old rwml-enclosure stack (2.0.0) together with the 2.0.4 switch and wrappers and that worked.

I am sure that more technical users can explain why this works.

regards
Hans


(Dos) #11

Sorry, it is with the 2.0.0 switch, but you can use the 2.0.4. wrappers


(Henridevries) #12

Maybe Will Woodgate can give a response to the solutions offered, thanks by the way Oos and Rovertek, because it feels like work-arounds, whereas I would like to know what is wrong and what should I do to make the Stack work as expected.

Versions: RWML 2.0.4 and XXL 5.0.0

Thanks.


(Rob D) #13

If I remember well, Will has mentioned that the old TsoojMedia-version and his new version could work together (I am not 100% sure). But when his version became available, I remade my site using it exclusively. Everything worked for me as expected. I did not have to use any workarounds.

I think the best solution for you, guys, would be to ask Will for help. Maybe create a simple sample project for him to examine? But you will have to contact him directly.

BTW, the way I use RWML is this: I put the RWML Master stack in a partial (with some other stuff) that goes on every page. I created 3 buttons for my 3 languages (images of national flags with text descriptions) for switching languages. These make up another partial that goes on all pages—underneath a banner.

I also have a language-switching bar next to the footer. This consists only of words.

Then, I use RWML Wrappers for content in each of my three languages. For me, this is the simplest way and it never fails.


(Will Woodgate) #14

For the record, the email I originally received from @Henridevries back on 22nd August was asking for advice upgrading from a much older version of RW - version 4 or 5? I offered to try open the project file in RW7 that had been shared with my via Dropbox, but it was too old and appeared to be corrupt. So I politely stated then that it would probably be best to ask Realmac Software or on these forums for help, because it was more of a general RapidWeaver issue, rather than specific to anyone of my addons.

Now that this discussion has switched-around to become more RWML-centric, then of course I am interested in helping. But the link I got messaged was dead and since then nobody has contacted me by email with a full support case for me to review. It is not easy for me to provide detailed support on the public forums. Especially where items of information like FTP access need to be exchanged securely. I hope you understand that we don’t want that sort of info shared for all to see.

So like I tell everyone, if you have any questions or comments that relate specifically to my addons, please make contact by email through the website. Supply all the relevant information and steps to replicate the problem. If you have a link to a test page, then great - but please make sure the link actually works before you send it! I have to try and balance the allocation of support time between many people, so anything that makes my job easier is welcomed and will ensure a better outcome.

We are already exploring more options for alternative RWML ‘switch’ methods for a future update.


(Henridevries) #15

Hi everybody,

Thnak you for your response. I’ve had contact with Will, he discovered the problem: at the server were 2 files. One page.html and 1 page.php. After deleting the page.html file, everything showed as expected. Thank you Will and others for their effort.

And@rovertek: my next thing to create will be the use of images like you suggested.

Bye,
Henri


(system) #16

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.