SFTP: can no longer publish


(Craig L. Adams) #1

My website host changed things from FTP to SFTP. Now I can no longer publish from RapidWeaver.
My password & other information has not changed.

This is probably something very simple. Any idea what might be going on?


(Doug Bennett) #2

Good, they made the change. Under publishing settings did you change you publishing method to SFTP (from FTP)?2017-11-30_13-34-28


(Craig L. Adams) #3

Yes. Other settings remained the same.


(Doug Bennett) #4

What happens when you try to publish?
Do you have any other FTP client software like FileZilla, Transmit or Yummy FTP? Can you connect with one of those apps?


(Craig L. Adams) #5

I get a reply that says:

Couldn’t sign in to your SFTP server
Couldn’t connect to server.

I have not tried other FTP client software yet, but I will (not soon, but I will).


(Doug Bennett) #6

who is your host company?
Did they give you any info on what the type of SFTP setup? Public key/private key etc.?
Have you tried the test button first?
Might want to go through this KB steps:


Also more info here:


(john) #7

Here exact the same problem since friday!! I can’t also upload my rapidweaver site to my domain. This works before friday perfect. Now Rapidweaver starts to upload via FTP and after 200 files of the 2000 files it give me an error message that it could’t upload to the server and completly freezes. I must Force-Quit rapidweaver and startup again.

Strange…


(system) #8

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.