Side bar Issues


(Gary Bunt) #1

New to RapidWeaver 8: I cannot get the sidebar to function on my blog page https://www.virtuallyislamic.com/blog/blog.php This is part of my research website, and the sidebar works effectively elsewhere on the site. As it is, on the blog, the content features underneath the blog posts. Help would be appreciated. Thanks


(Rob Beattie) #2

I don’t have the theme but it looks to me as though you’ve got other stuff on the page (a Twitter widget and a custom search) which may be interfering with the blog sidebar. I’d make a copy of the page and then take everything out except the blog and see if the sidebar appears where you think it should be. Then add in any other elements until you discover the culprit.

Rob


(Gary Bunt) #3

Thanks Rob. I will give that a go. I have only just added the Twitter widget, so that’s one less possible culprit.


(Jason Bostick) #4

What do you have as your settings for main content and sidebar content? I don’t have my RW computer handy to give specifics/screenshots but I believe your theme has an option to set the width for each. They should add up to 12 or else your content will get pushed below.

Edit, found a screenshot. This is what I mean:
New%20Picture%20(1)
If you make it so the main content is, say 8 and the sidebar is 4 (12 total), it should show up on the side as expected.


(Gary Bunt) #5

Thanks very much for responding. I will take a look at this later on and see if it works.


(Gary Bunt) #6

Unfortunately it is back to the drawing board. Nothing so far has worked. I’d appreciate any further ideas. Thanks


(Jason Bostick) #7

Have you published the changes? When I use the browser inspector and I change the columns, I can get the sidebar to show up, which is why I thought that may be the issue.

In this first screenshot (you may have to click it to expand it big enough to read), the columns seem to be set to 7 and 7.

In the second one, I have them changed to 6 and 6 (I also removed the animation that was set).


(Jason Bostick) #8

Here’s one with the columns at 8 and 4, which is likely a more appropriate ratio.


(Doug Bennett) #9

I verified what Jason said, the columns settings are still at col-sm-7 for both the sidebar and the content area:


(Gary Bunt) #10

Thanks very much for the advice. I will take a look at this and have a go at making the changes. My coding is a little rusty, so your diagrams are very helpful!


(Gary Bunt) #11

Thanks for all your advice. Unfortunately I was unable to find a way to do this. I adjusted the columns in the Master style, but it stayed the same for the blog after I published the website (tested across platforms). Maybe the Mountains theme is fixed in Rapidweaver 8. There’s probably a work around out there. Rapidweaver needs a more detailed set of advice/manual.


(Jason Bostick) #12

And just to double check, are you sure you don’t have different settings for the blog page in the page inspector (that are overriding master styles)?


(Doug Bennett) #13

The Montain theme is a RapidWeaver 8 theme. I tested it, and it seems to work fine (if the settings are correct) with the built in blog plugin.


(Gary Bunt) #14

Thank you so much for your advice. The blog now works. :grinning: After looking at your posts, I switched the theme back to default (somehow I had it on another setting). Really appreciate your help.