Snippets have vanished


(Robert Bassett) #1

Weird goings on. I was using RW up until yesterday evening and everything was fine. Today, my Snippets have all gone. An empty box. I’ve restored the app from Time Machine using a version from yesterday, and also tried a clean copy downloaded from Realmac to replace the existing, but still no snippets. Reference to the Snippets folder in Library/Application Support/Rapidweaver/Snippets shows a list from various developers, but not the ones that I created personally. I tried installing one of these snippets, and it subsequently appeared in the Snippet list - but it’s the only one!

Has anybody any idea why my original list went missing. If I do need to rebuild it, is there any chance I can retrieve the ones I created personally?


(Greg Schneck) #2

If you are using version 7 you have the wrong path to the folder. It is Library, Containers, com.realmacsoftware.rapidweaver, data, library, application support, rapidweaver, snippets.

Have the Snippets folder open (so it will appear in Time Machine) and then go into Time Machine and step back thru the folder and see if they appear at some point. They should be there back in time at some point.


(Robert Bassett) #3

Thanks for that Greg. I went back a couple of days and they were there. Restored with Time Machine and everything seems to be working now. Bob


(Robert Bassett) #4

Well, it was almost back to normal. Another bit of weirdness in fact. I have a snippet that centres an imported image.

This worked fine before the earlier trouble with the snippets, but failed after I restored them. On inspecting the element, for some reason the IMG SRC attribute had two sets of double quotes ("") on either side in the generated code, as did the center attribute in the DIV, rather than single ones. I can work around this by omitting the quotes in the IMG SRC and center attributes within the snippet, but don’t really understand why this happening. I copy the source destination using Yummy FTP and have pasted the result into TextEdit to check that it is quote free, which I expected having been using this method extensibly over the past few days without problems. So it seems that the snippet may in some way be responsible, or RapidWeaver itself, but I’m at a loss to know how, as it has only been happening since the previous problems.


(Robert Bassett) #5

I think I’ve resolved it. It seems that the snippet text had some hidden formatting. Not sure how that happened but cutting and repasting as unformatted text has fixed it.


(Scott Lee) #6

If your time machine won’t let you restore your snippets then check if your mac has updates waiting. I followed Greg’s directions but the time machine would not let me restore what was there, so I checked for updates…there were a couple and after updating my imac my snippets reappeared after opening up rapidweaver.


(Brian LaPan) #7