SOLVED - Formloom import to stacks not working - turned on SSL in Formloom settings


(Lisa Sandler) #1

I am using formloom 3 and followed the instructions to import the formloom page into a stacks page, using the remote stack.
It was kind of working but then it started only showing part of it.
https://www.lisasandlerphotography.com/contact/


(Keith Flanagan ) #2

Do any of the Stacks around the FormLoom3 Remote stack have Zindex values that are adjustable? It seems to be a problem with one of the stacks zindex values being too high and hiding your Formloom 3 form.


(Lisa Sandler) #3

Yes, actually. Good call. I am using stacks4stacks Banner Stack that has layers. I’ll try adjusting that. thx :slight_smile:

Well, that worked only if you go to the contact page once. After that, it’s messed up again. If I link from other pages or reselect the contact menu, it gets cut off again.

Any code to force the remote stack to be on top?

oh… it seems to work on iPhone and iPad but not my desktop.


(Stuart) #4

There are a selection of errors on that page which you should be able to see in the console. I definitely recommend that you try to address them where possible.

Try adding this CSS:

.VolcanoVertPad {
	height: 1280px;
}

iframe {
	height: 1200px;
}

To that page. But Its messy and it would be better to use stack/theme options to correct the issue of container and iframe heights instead.


(Lisa Sandler) #5

Thanks but that did not seem to work :frowning:

I am not a programmer so I mostly know what the errors mean and how to fix them.

I definitely don’t know how to fix anything that says unexpected CSS or Invalid CSS property:
[Warning] Unexpected CSS token: : (formloom-page0.css, line 1)
[Warning] Invalid CSS property declaration at: * (formloom-page0.css, line 1)
Will be looking into this a bit later.


(Stuart) #6

Maybe need the !important tags:

.VolcanoVertPad {
height: 1280px !important;
}

iframe {
height: 1200px !important;
}

Seemed to work okay to reveal the form in the Chrome inspector when I looked at it earlier. Not sure what the VolcanoVertPad element is… but I would maybe start with looking to see if there are any UI options available to control the height of that.

Also, did you re-publish? I cannot see that CSS being applied (even non-functionally) on those elements on the page…


(Lisa Sandler) #7

Thanks. I’ll try that and also ask @willwood about the volcano theme code.

I republished but since deleted and republished. I’m a mess lol. Getting there with everyone’s help.

Well, it sort of worked. It also gave me sliders on my EC 3 banner content, which I did not want. I’ll reach out to Will.


(KC) #8

As you’re using https, have you selected ‘SSL mode’ in the Formloom security settings?
I’ve seen this partial loading of a form whenever I forgot to select this option.


(Stuart) #9

Well, it sort of worked.
Well, I’m sort of pleased :wink:

I see the form looks ok now ( using an iPad just now ). What fixed it?
I’m curious to learn how increasing the height of these elements could have put content there ( that wasn’t there already ).
Anyway, glad it’s looking better.


(Lisa Sandler) #10

No. it always worked on iPad and Iphone, without the code. The issue has been with on my computer. I took the code out again because iit added scroll bars to my banner area. I’m sure it just needs tweaking and I have some other things to ask my theme developer about so will add this to the list.
Thanks again :slight_smile:


(Lisa Sandler) #11

@bigsy I think that did it! thank you!


(SF) #12

Thanks for this. I just migrated a site to SSL and could not figure out why iPhone/iPad worked fine, while desktop didn’t Big thanks!