Focus and Formloom problem


(Jason Bostick) #1

Is anyone able to troubleshoot the errors I’m getting on this site? I’ve put a request into Yabdab and Elixir but Yabdab is away currently (and it doesnt seem to be an Elixir issue).

Anyway, I’m trying to use a Focus and Formloom3 Remote stacks as a Contact Form. Instead of showing up in the pop-up, it is just stuck on the bottom of the page. (The homepage has 3 because there’s 3 seperate headers based on screen size - long story).

The Safari inspector is showing a boatload of errors but I don’t know how to interpret them. Site is here:

Any help would be greatly appreciated.

I’m using RW7 and Foundation.

EDIT: The issue doesn’t occur on this test site for some reason. It only showed up when i published to the registered URL (both domains are on the same hosting provider).


(Brad Halstead) #2

@jabostick

Your FormLoom Remote is in your Focus stack correct?

For your FormLoom Remote Stack, how did you link the page (Via Page in Link maker or via URL?) If URL, verify the URL has been updated for the actual site from your test site…

FormLoom page must be set to not show in navigation (Obviously set from your test build site)

Do you have a Base URL set that maybe is causing a cross-domain issue?

All I can think of off the top of my head without seeing screenshots of how implemented.

Brad


(Jason Bostick) #3

Here are a few screenshots. A few of the settings, and one showing that there’s nothing visible placed below the footer.

I think I’m doing it right. I literally just changed the URL and publishing path from the test site, so the stack settings weren’t altered. And I’ve been using the ‘Set Link’ and selecting a Page, as opposed to inputting a specific URL…

Anyway, off to bed for me.





(Brad Halstead) #4

Everything looks correct, my only suggestion from here would be to remove all files and folders from the server, mark all files as changed in rapid weaver and republish and see if that resolves the issue.

I’ve not used the focus stack in a block grid before, just a multi-column stack as a partial and it worked fine for me, from test domain to actual domain. Caveat… I don’t use TCMS on my site but I doubt that is the issue as it worked on your test site.

Domains match in your FormLoom page for emails/smtp settings? (Not related, just trying to save you further grief lol)

HTH a little…

Brad


(Jason Bostick) #5

Thanks for having a look, Brad, I’ll try that.

The smtp setting… Will they need to match? He has a gmail account that I was going to use. That might be a problem though, I take it?


(Brad Halstead) #6

In my experience with FormLoom 3, yes. The instructions are quite clear on the issue.

You can use a gmail account, just turn off SMTP… has worked for me anyway in most circumstances. In others I had to use a valid email address from the domain used…

Brad


(Jason Bostick) #7

Turns out it was a conflict with the Structured Meta Data part of Joe’s SEO Helper stack. I’ve removed that and it is working now, in case anyone else ever encounters the error. Thanks for having a look for me @Turtle