Some help on Armadillo please


(Dave Hughes) #1

I am replacing a news page with an Armadillo based blog. The test page can be found here:

www.friendsoferlestokeprison.com/test.php

I have used Armadillo successfully on other sites using exactly the same theme (Foundation)

However, there are a couple of things which make me think I am doing something wrong (and it happens in different browsers).

  1. Try as I might, I can’t get the admin login to appear on the page. It is set to show in the settings section of the Armadillo online CMS page, the font colours are fine. Anyone have a clue what might be going on ?

  2. In the Armadillo navigation stack showing on the right, I have an errant bullet point appearing below the tag list. I haven’t got any tags that are just spaces (my first thought) but as the bullet is spaced out from the tags it looks like it might not be a tag.

  3. I have an Armadillo headline stack at the top of the page (only temporarily whilst I test - will end up on the home page). One of the options in the stack is to preview the body text and you can set the number of characters to display. The initial setting is 140 characters - I tried to enter a higher number to show more but it defaulted back to 100. So now I can’t even get it back to 140 (well I can if I delete and re-add the stack). Is there any way to increase the number of characters above 140 ?

  4. Finally (honestly), the ‘Show more posts’ button at the bottom works fine in Safari, in Chrome, the button just disappears when clicked and doesn’t show any more posts. No ideas on this one!

And before you ask - I’m no CSS. PHP or anything else expert :smile:

Thanks

Dave


(Brad Halstead) #2

@davehughes

RE Issue 4: I don’t use Armadillo, but in latest version of Chrome (Version 46.0.2490.86 (64-bit)), the “Show More Posts” button works as advertised.

RE Issue 2: The extra .(DOT) or bulleted list item is just that, there must be an item with a space or something causing that somewhere in your content/menu list on the right side.

RE Issue 3: No idea

RE Issue 1: Are the field background and text colours different?

That’s about as far as my help goes with this sorry. Hope it helps even a little.

Brad


(Dave Hughes) #3

Thanks for the reply.

Not sure what is up with the disappearing buttons as they seem to work fine on other machines. Time for a clean up on mine I suspect as something is misbehaving.

In terms of the login button, all of the relevant colours are set differently so I have given up and simply created my own log in button.

As for the elusive extra bullet, I agree with your thought, but can I find it…:worried:

Dave


(Brad Halstead) #4

@davehughes, do you use a stack to generate the link list?

Perhaps there is a page that has no page title that is causing the elusive li marker?

Just more thoughts…

Brad


(Dave Hughes) #5

Yes - its a navigation stack but has no options. All of the options are accessed through the online CMS page. Have tried all the options in there and no luck. I have dropped an email to the developer.

I am guessing it might be an interaction with the theme I am using (Foundation) that is triggering it - but I have used them together a number of times and can see no difference from previous times!

The hunt continues…

Dave


#6

Make sure you have the latest 2.5.7 version. I think the navigation issue was fixed in a recent version so sounds like you may not be fully up to date.

Also make sure you don’t have a blog stack and the main Armadillo stack on the same page. I created a dummy page to hold just the Armadillo stack.

Foundation and Armadillo are fine together.


(Dave Hughes) #7

Thanks for the reply

Already using 2.5.7 so that doesn’t seem to be it.

Interestingly, I just had the main stack on the page and no blog stack and it showed correctly. However to attempt to fix it I created a hidden page, put the main stack on that and added the blog stack to the news page. Exactly the same errant bullet (and still no log in showing - but put an alternative in already to cope with that.

The hunt for the bullet continues…


(Pedro Perdomo M.) #8

just guessing about the bullet,
it seems that you’ve created a tag but you does not wrote the name

Best


(Dave Hughes) #9

Hi, was my thought too but the tag list is complete with no empty lines (i.e. a tag with spaces/no name). The bullet is also offset from the other tags by a short gap which suggests it is something else.

Thanks

Dave


(Stuart) #10

It’s got to be something to do with ‘authors’. If you are really stuck you could use:

div#blog-post-authors {
    display: none !important;
}

To get rid of it. But thats got to be a last resort and is a bad idea.


(Mathew Mitchell) #11

The “read more posts” link works fine for me. Not seeing the problem.

As @kryten has indicated the extra bullet probably has everything to do with you choosing to display authors. (You can see an empty space just to the right of “by” in the top of each post). You need to go into the Admin panel, then Settings, and then choose to not view authors. Then all should be fine.

On another note it’s confusing that your headlines (I know they’ll be moved) and the titles for blog posts are not colored blue (as with other links). This means it’s not obvious to a user that this are active links. I’m not sure why this happened, or if it’s a Foundation setup issue.


(Dave Hughes) #12

Thanks all - it was indeed authors. They were set as off but were still attempting to display a nameless author. Cycling them on and then off removed the bullet.

I know what you mean on the headline links - will dig into that but not as critical.

The Show More posts button works on every machine but mine so there is obviously something wrong with my mac - I’m going to do some housekeeping and see if that sorts it.

Thanks for all your help

Dave