Your Foundation Stacks are out of date. Please update to version v

I created our website a few years ago. Have been upgrading RapidWeaver and Foundation as they come out. Two weeks ago, I made a few tweaks and republished the site. It seemed to be fine. Today, I went in to add another tweak and I’m suddenly getting errors. They are also showing up online.

My home page shows three errors in preview mode:

Your Foundation Stacks are out of date. Please update to version v. (not a typo, there is no version number after v.) I have checked, and all stacks are up to date. Add-ons shows Stacks: Foundation 6.8.9 and Themes: Foundation 6.8.9.

**Your Foundation Theme is out of date. Please update to version v. **
Download the latest theme from https://foundationstacks.com/theme/download As above, the theme is the latest.

Foundation theme not applied! Please set the Foundation theme as the theme for this project The page theme says “Foundation”.

My Home page doesn’t work when published. It won’t show my TopBar menu. If I go to any other page on my website, they all work fine and look normal. I have TopBar in a Partial that has a Structure with a Site Styles, text, and TopBar in it. The Partial is the heater on every page. The menu displays and works fine on every page…except the home page.

I’m missing something simple.

If you are using Foundation v1, then you need to get the Foundation v1 theme from

I went to the link and downloaded the Foundation 1.8.1 Theme and installed it. It shows up in Addons->Themes. Restarted. Same messages. I noticed that in Addons->Stacks Foundation 6 is there, but there is no Foundation 1.8.1. There are the Starter Pack 1.9.3, Addon Pack 1 1.9.3 and Add-on Pack 2 1.9.3.

Did you make sure that F1 theme is set as the theme of the project?

All my pages have “Use Master Style” selected. Below that, greyed out, it says “Page Specific Theme” and “Foundation” is selected. If I click on “Edit” next to “Use Master Style”, it takes me to Master Style, and the only item is “Theme Styles” and the only choice is “Theme Default”.

Is it selected in the Theme ‘drawer’ though?

Yes it is. I also clicked on several pages, and checked to see if it was still selected (didn’t know if it was page dependent).

Anyone have any other suggestions. Still not fixed. Contemplating total rebuild based on Foundation 6.

Go into RapidWeaver preferences (or the addons button on the top bar)

  1. Select Addons
  2. Select Themes
  3. Select Joe Workman
  4. Check the Version number for the Foundation Theme (NOT the Foundation 6 Themes)
    2021-06-05_12-24-43

    Now check and make sure the Foundation One Stacks are up to date,.
  5. Select Site Styles in the stacks library (Make sure it Foundation 1 and not 6)
  6. Check version number
    2021-06-05_12-32-31

Make sure you are using Foundation 1 stacks with Foundation 1


The Foundation 6 stacks will not work with F1 and vice versa

2021-06-05_12-38-22

3 Likes

Thanks for the suggestion. Still no joy. All my version numbers match and my site styles is the Foundation 1 version. I even “Unchecked” the Foundation 6 boxes to make sure that wasn’t interfering.

Do you have a published page that I can look at?

It’s online with the errors at:

www.esp-nw.com

The home page has the errors, the menus don’t even show up. However, the menus on all other pages work, and don’t generate any errors. They are all using the same partial that contains, site style, a three column stack, and a top view menu.

for example: www.esp-nw.com/Heating/GasInfraredProducts/

First. Take this code out of your page head place it in the Body tab in the page inspector or site wide code…

You also have some bad headers getting sent by the web server. I assume that you did not configure this so you should talk to your host about it…

None of the above is causing the version issues but those are bad and need to be fixed.

Now onto your Foundation versions. You have the following on the page.

  • Foundation Stacks v1.9.3 - Great. This is the latest version
  • Foundation Theme v1.7.4 - Not good. This is very very old. You need v1.8.1. You can get it here… Foundation v1 Theme

Delete all Foundation v1 themes. It seems that you have Foundation 6 as well. This means that you should have the following themes installed in the RapidWeaver addons folder in Finder (cmd+7). You can safely trash any other Foundation theme that you may have installed.

CleanShot 2021-06-07 at 12.12.15

1 Like

Looked in Addons->Themes, and v1.8.1 is what’s listed in Rapidweaver. I unchecked it. Closed Rapidweaver to make sure it was gone. Installed it from your link. It shows up as v1.8.1. Still have the same problem. I wonder why it’s showing up as v1.7.4 in the code that is published?

As I recommended, look at the addons folder in Finder. You most likely have multiple installed. This is why I recommended that you do it this way.

Here’s my Addons folder. Do you see anything that could cause this?

Why do you have Foundation-2.rwtheme? That is not what you want.

When I clicked your link to download it, it put it in my downloads file. However, since I had already downloaded it a previous time, it tacked the “-2” on the end. I deleted all copies of the theme, and downloaded again. Installed in Rapidweaver. Now shows “Foundation.rwtheme”. Version in Rapidweaver says 1.8.1. No change…still giving me the same error.

What’s very strange to me is that the home page has the problem, yet all of the other pages on the site (which use the same partial that contains the menu) work fine.

Other thoughts: Mac is running OS 10.12.6 (stuck at this version until our CAD vendor updates their app). Have Rapidweaver 8.8.3. Could that be causing something? Should I try re-installing Rapidweaver?

The old version is still somewhere then. Do you have older versions in the Theme Disabled folder? What version shows in the RapidWeaver Addons manager in preferences?