Split Theme publishing without header image


(DR) #1

Hello. I created a site using the Split Theme and it looks great in preview mode within RapidWeaver. Everything works perfectly. But when I publish, the header only appears on the home page (it is a big gray blank on other pages). This is true whether I publish locally or FTP direct. I have confirmed the required image is in the published resource folder. I have been pulling my hair out for a week trying to figure out what’s wrong.

Originally, I wanted a unique image on every page so added some CSS code to change the image on each page. Again, this worked perfectly in RW preview but wouldn’t work when published.

So I stripped all that CSS out (so each page would use the same image) and still – the header image only appears on the home page.

Any wisdom would be much appreciated.strong text


(scott williams) #2

Pretty tuough to help without a url


(DR) #3

It’s not public but this is the error message I’m getting when I inspect every header but the one on the home page.


(scott williams) #4

Just to be clear, you get that message after republishing all files (file menu) to an actual web server?


(DR) #5

Hi, Scott. Thanks for helping. Yes – I republish all files every time to be sure. I’ve tried it both locally and to a web server. I’ve even manually deleted everything and republished from scratch (many, many times). Not a cache issue either. I just found an old thread from a year ago with a similar problem (header only publishing on home page with Split theme) but it wasn’t resolved. I know it’s nearly impossible to troubleshoot without seeing the web site itself but I was just curious if anyone else has experienced this and resolved it.

I’m by no means an HTML expert (which is why I’m using Rapidweaver) but I’ve usually been successful troubleshooting. This one has me stumped. It’s frustrating because everything looks great in the preview but seemingly won’t publish accurately.

If this is any kind of clue, when I inspect the element within the Rapidweaver preview (in which it works) the HTML says localstorage but when I inspect the element after published it says no-localstorage. Forgive me if that’s a red herring – again, I’m no expert and flailing.


(DR) #6

Scott – to follow up, I figured it out from that error message. It’s looking for the image in a resources folder WITHIN the page’s folder rather than the main site’s resources folder (which is where RapidWeaver is putting it when it publishes). So I manually added a resources folder to each page’s folder, with that image in it, and it worked. Not sure if that’s a Split Theme bug or a Rapidweaver bug or something I did wrong but I’m happy for the workaround.

If you have any wisdom for simplifying that workaround, I’d appreciate it. And thank you for responding!


(scott williams) #7

Do you have your pages set to use the master style?


(system) #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.