Stacks 3 is sooooo sloooooowwwww in RW7.1 ***Fixed with 7.1.2***


(Jonathan Spencer) #1

Has anyone else had problems with Stacks 3 being soooo slow in RW7.1 and 7.1.1? It is taking 10 or more seconds to edit a text stack and is taking 100% CPU. I have tried a non stacks project and it runs just fine with no lags at all. I might see if there are any betas out of Stacks 3 but it is making RW unusable at the moment.


(Isaiah Carew) #2

that seems very odd. is it related to one particular project perhaps?

if you close all projects, create a brand new one do you notice the same thing?


(Jonathan Spencer) #3

A new project is fine until I start to add images into the mix, I always optimise my images and make sure they are as small as possible. I can’t try it on my MacBook Pro as I spilt wine on the keyboard and it has died! It has only happened since upgrading to 7.1.1 but I dropped back to 7.1 and it still behaves the same. Moving stacks around is becoming slow as well and is pretty much unusable. My %CPU is going to around 100% when moving a small block of normal text within the edit window. I don’t think my 8 core 2.93GHz Xeon, 22GB RAM, 480GB SSD is up to the job sometimes, Rapidweaver certainly seems to test my system more than any other I use!


(Isaiah Carew) #4

Stacks is designed and built on almost that exact machine: 8 core xeon – so i would expect it to work the same here as there and I definitely don’t see anything like that.

I suspect there is something particular about a specific file, specific image, or specific stack that’s causing the issue.

Could you zip up the smallest file that you have that behaves this way (if you can make it do it with a single image on a single page – awesome!!! – if not then whatever works) and then share a dropbox link with me.

It’s important to eliminate as many 3rd party stacks from the equation as possible. If the problem will only happen with those in the mix too – then you’ll have to include those – and send via a private message.

With that example in hand I’ll be able to tell you exactly what is causing the slowdown and either help you work around it or if it’s a bug, fix it.

Isaiah


(Paul Russam) #5

You wouldn’t be using an external monitor and upgraded to Sierra would you?
There is a problem where kernel_task (I have it) and the Mac runs like molasses.
https://forums.developer.apple.com/thread/49163


(Jonathan Spencer) #6

I have a Mac Pro with two external monitors running Sierra not the MacBook Pro’s that seem to be experiencing problems. No doubt running a new OS then a new version of RW7 doesn’t always help, I’m a sucker for betas and the like!


(Paul Russam) #7

Are you using a Logitech Mouse?
A bit more poking around the interweb seems to be indicating that the Logitech driver may be the culprit.
https://discussions.apple.com/thread/7690198

I’ve just unpaired/repaired my device (keyboard in my case) and the CPU usage of kernel_task went from 700% to 2.2. I’ll keep an eye on it but so far so good.


(Isaiah Carew) #8

I have a nearly identical setup. I have a 6 core Mac Pro 2 displays. It ran at 100% CPU for about 3 days after installing Sierra. First for spotlight to re-index all my drives, then for Dropbox to repopulate, and then for Spotlight to re-re-index, then to install Xcode, then for spotlight to… you get the idea. :wink:

Needless to say, indexing after a major install kind of makes your mac pro feel like a MacBook Air for a few days. So if you’re in that zone, then give it some and attack the problem afterward.

…BUT…

you said:

“A new project is fine until I start to add images into the mix”

This would really seem to indicate it’s something not related to hardware or drivers and such. If the problem comes and goes depending on which file you’re using, then it’s really likely to be something in that file. If there is one particular file (or several) then start your search for a culprit there.

Isaiah


(steve connolly) #9

Very interesting. Ive been using RW for a long time now and its always been an absolute delight, but over the last few days pressing that “preview” button has become painful! its used to be instant, but now “waiting for stacks”, wait, wait - I know its only a few seconds, but it has lost its thrill.

This is using a project have had on the go for ever.

Im on 7.1.1. Its has been asking me to update but fails everytime?


(Isaiah Carew) #10

@flythedog -

It could be this???
The major difference between RW 7.0 and RW 7.1 is that the pages are loaded only when they’re needed. Of course, loading the document does have to happen eventually – it now happens later, usually as you’re interacting with the document.

On the other hand, it could just be something to with your document? But I’m afraid without more specific information I’ll probably just send you off in the wrong direction. If you’d like us to take a look at your document you can share it (along with any stacks it uses) to support@yourhead.com.

We can open it and give you much more specific information about what is causing the slowdown – or if it’s a bug, we’ll be able to fix it straight away.

Isaiah


(Brian LaPan) #11

7.1.2 is out now, try that.

download here if the auto updater isn’t working for you


(Jonathan Spencer) #12

Thanks for all the speedy replies. I upgraded one of my versions (I keep several, just in case) to 7.1.2 and everything is working smoothly again.

Rapidweaver is one of my most used programs and I have invested a small fortune on the add-ons but it also causes me no end of headaches.


(steve connolly) #13

Thanks guys, helpful as ever :slight_smile:, Have now upgraded to 7.1.2 and no difference unfortunately. Ive included a screenshot of the two messages I get. I have also tried 3 different projects, different themes, different things going on and they all do the same. As mentioned already all worked wonderfully only a short time ago.

PS: How good are Stacks anyway! apart from my slight issue I love em, life without them I just carnt imagine.


(Jonathan Spencer) #14

They are the normal messages you get when Previewing a page. They shouldn’t last more than a few seconds depending on the complexity of your project.


(steve connolly) #15

Thanks, I’ll persevere, looks like I was lucky previously with the amount of time it was taking which was considerably less.