Suddenly cannot publish


(michael french) #1

Have been using rapidweaver for years with no issues. Suddenly now getting “couldn’t sign in to your FTP server” when I try to publish or test.

Have upgraded from version 5 to version 7. Worked with Little Oak hosting and they assure me all the loging data I am using is correct.

Any thoughts?


(Doug Bennett) #2

A screenshot of your publishing settings might help.

Do you get the error when you hit test?

If your server name and password are correct, (as per little oak) then clear the path out, try the browse button.


(michael french) #3

Didn’t help. I cleared the path field and when I selected browse it only gave me the error message again that my sign-in details are incorrect.


(Doug Bennett) #4

What happens when you hit the test button (with path cleared)?
Have you tried reentering your username and password?

You can go through this help post:


(michael french) #5

Cleared path and when tried test got same error.

I did not see anything in the"fool proof guide" that helped. Could be just me.

Attached is screen print


(Mark Sealey) #6

ftp vs sftp: could it be that your host has started requiring the latter; it’s more secure?


(Don H) #7

You could try with an FTP app to confirm that the authentication/path info is correct. I think someone else recently had a similar issue and even though they checked with their hosting provider, the info was still wrong.

Btw, is that publishing setup for a draft version? The website address doesn’t look correct. You should not have “/index.html/” on the end of you domain.


(michael french) #8

This is not a draft. The “/index.html/” appeared when I recopied the site address today. Don’t know which is right but does not work with or without.


(Jason Bostick) #9

I’d agree with Don that your web address looks odd. But also your path. It doesn’t typically have the web address included. And according to this article, Little Oak (which I don’t know if it’s up to date or not) advises to only put /www in the path

https://www.littleoak.net/knowledge/2069.html


(michael french) #10

No change using “/www” only.


(Matthew Long) #11

Can you access your own website directly from your browser using the machine that you use to publish? Or do you get a “Can’t find server” message when looking at your website directly on the internet?

The reason I ask is that Little Oak has an automated security process that will occasionally put my own development machine on an IP ‘blacklist’ and stop me connecting if I do anything that annoys their security settings and makes my activity appear ‘malicious’.

The thing is, the only thing that seems to set off their blacklist is using the Sitelok membership system admin page - or more specifically, if I leave a browser tab open with the Sitelok admin page running a plugin called “whoisonline”.

I don’t want to bog down here and derail the conversation, but my point is that it took me a long time to work out why Little Oak would periodically stop me accessing my website (via FTP or even just when trying to look at my own site over the internet). It came down to a webpage that was making to many Ajax calls and Little Oak didn’t like it.

So now if I suddenly find that I can’t access my site or connect via FTP, then I log in to my Little Oak Admin Manager - and usually there is a nasty warning sign waiting for me as soon as I log in that says “Your IP address has been blacklisted”. However, you can then click on a button to remove the block and get back to normal functioning. This very situation happened to me today…


(Doug Bennett) #12

The server name being just an IP address, would be hard to tell if it’s correct. It’s been years since I had a website at little oak, but looking through my old bookmarks and the server name was:

ftp.yourdomain.com

The path was: /www
Generally if you have the path cleared out and hit test, and still can’t connect, there’s usually something wrong with server name, username or password.
If it was me I would test those credentials with a FTP client like transmit. If you don’t have a stand-alone FTP client you can get FileZilla, it’s a free open source FTP app that works very well.


(Doug Bennett) #13

If I remember Little Oak, will use a path name with a url in it if it’s not the primary domain on that account.

But if you clear out the path and hit test and still can’t connect, you’ve ruled out the path being the issue.


(michael french) #14

Really appreciate all the suggestions. None helped so a little at a loss as to where to go next. Guess I’ll cycle back to Little Oak but they were pretty clear that the entries were correct.


(Mark Sealey) #15

One more time: sftp or ftp?


(michael french) #16

Little Oak was happy with ftp. Just tried switching publishing method to sftp - no change.


(Don H) #17

Did you try with an FTP like FileZilla?

If it doesn’t work with an FTP, you can rule out RapidWeaver. It will also be much easier for you to deal with support at Little Oak if you can tell them you can’t connect with Filezilla.


(Rob Beattie) #18

Try changing the server name to the name of your website - i.e. www.yourwebsitename.com

Then change the Mode setting to Extended Passive and try again.

Rob


(michael french) #19

And so it goes, same message “your sign in details are incorrect”


(system) #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.