Terrible upgrade

Hello, after many hesitations (RW ver. 8.5.1 worked fine) I upgraded to the latest version 8.8.3 Unfortunately this version crashes (freezes) and I have to do a forced quit from the application. Also, not all of the thumbnails on my site are visible (see attach). To upgrade RW I opened the old version and followed the instructions on the screen (Stacks was also upgraded). But version 8.5.1 is still present on the computer (see images) and if I open this one I see more thumbnails than the 8.8.3, although not all. My site is visible at www.mbernardi.it
Is it possible to downgrade to version 8.5.1 (which worked perfectly) and delete the latest upgrade? I have a Mac with Big Sure. Thank you
Massimo

I’m not sure what’s going on there. The RW update should not be causing those issues. You can download to earlier versions of RapidWeaver here: RapidWeaver Release Notes

If you wish you can just delete the newer version of RW to see if that resolves your issue.

What version of Stacks are you running? The thumbnails looks like it could be a stacks issue (as it’s on the Stacks UI). Perhaps @Isaiah could chime in, he might know what this is?

Dan many thanks for your reply. I will try deleting present versions and installing again RW. Also I noted Stacks version is not updated to the latest one so I will upgrade it too. I’ll keeo you informed.
Best regards
Massimo

I’m having the same problem. It freezes and also it’s corrupted many files. I can’t seem to follow tutorials either for new themes as there are come changes. Driving me nuts