RW 6.3.7 Upgrade


(Steve H.) #1

I just installed the latest update. Within the first 5 minutes RW froze twice. Typical. The first time preview failed. The second time the stack update locked things up. UGH.


(Nik Fletcher) #2

If you’re able to recreate these issues, please drop us an email with some more details!

support@realmacsoftware.com


(Brad Halstead) #3

@i2insights

Things that will help troubleshoot…

  1. Have you tried a reboot of your OSX?

  2. What version of OSX?

  3. If using Stacks, have you updated it to the latest version?

  4. Have you performed an update on your stacks to have all stacks to their current versions?

  5. Is it a specific Theme or all Themes?

  6. Is it a specific stack or all stacks?

  7. Are there steps to reproduce this?

  8. Is the Crash reporter opening and are you sending crash logs to Realmac?

  9. email results to support@realmacsoftware.com including logs and perhaps project file for troubleshooting.

Personally, I had some issues with my machine after updating the OS, after a reboot, all was well (NOT RapidWeaver specific).

Hope that helps
Brad


(Steve H.) #4

No error report was generated. I had to use force quit.

  1. I did not reboot.
  2. OSX = 10.11.12
  3. Stacks 3.0.2
  4. All my Stacks were up to date prior to the RW update. RW crashed when I tried to check for new updates.
  5. I was using JW’s Foundation.
  6. No specific steps, use it long enough an RW will trip over something.
  7. The crash reporter did not open. Although, RW’s crash reporter often crashes itself.

(Brad Halstead) #5

@i2insights

  1. I suggest an OSX reboot and test again

  2. @isaiah has a version of 3.0.3 of Stacks posted somewhere on the forum which corrects some issues.

  3. @joeworkman has an update to Foundations Theme 1.5.5 if you were not prompted to download it about a week ago.

  4. Not my experience but everyone’s machine is different.

HTH
Brad


(paolo savonuzzi) #6

same here

  • updated to 6.3.7
  • launched and checked for stacks updates
  • clicked “Update All” and… RW crashed whilst downloading the first update

further issue is… now it says there are no available updates
already seen all this in 6.x :rolleyes:


(George Peacock) #7

I am also having problems with this release . Cant publish and having multiple crashes. I really really should not have accepted this update. All my stacks are up to date and am using Foundation. When publishing it seems to miss of quite a few stacks and stack elements i.e not getting the full pages published.

Guys - unless I am missing something you need to check your software out more before sending as general release - we are on 6.3.7 now and I for one will do without new features for a while I just want a version that works.


(Ric) #8

I did a stacks update yesterday and crashed and I’m on 6.3.6 so it’s not necessarily something introduced in 3.7.


(Rob D) #9

I am 100% behind this statement/request. Every time there is a new update, it fixes a little and it breaks a little. You definitely need more testing on more machines with more configurations. We need less updates but more solid ones.

I have 6.3.7 on MacPro with Mavericks and on MacBook Pro with El Capitan. The Mavericks version saves Quick Look Previews and the El Capitan does not (same settings in Preferences).


(Brad Halstead) #10

@Rovertek

Not my experience at all on El Capitan. Try turning off Quick look previews, restarting rapid weaver and turning it back on. I didn’t have to do that but some did. Did you perform a clean install or upgrade to El Capitan? I did an upgrade not a fresh install myself…

I use a Mac-Mini - Mid 2011 with 16gb ram and i5 processor, 6tb raid 5 array, 2tb time capsule and a Samsung monitor

Please, I invite you to join the next beta program of RW, the more people beta test, the more people have a say in what is broken and what is not and more configurations can be tested. Currently there is no beta, but generally speaking, my experiences with beta’s has been very reliable and positive.

The user base must participate as much as possible in the beta cycle as Realmac cannot be expected to have every configuration of Mac’s available to them for testing with every version of OSX. Imho.

Brad


(Robert Ziebol 🖖🏼) #11

Just wondering if you download the beta’s that Realmac releases?? If you want to be sure the next update works on your machine, I would start doing so, so you can help Realmac make sure it does. I run RapidWeaver on 4 different machines, and it works great on all 4. One even has Stacks 2 installed (for support issues) and that has no issues. If you think they need more testers, be sure to grab the beta’s and help out!


(Rob D) #12

@Turtle,
I tried your suggestion. It did not work for me.

No, I did not perform a clean install of El Capitan. It would be impractical, since I have hundreds of gigabytes of apps, documents, workflows, settings and licenses to re-install at every OS upgrade. Only about 15% of my apps come from the Apple Store. I don’t have time to go through all the rest and manually set them to the previous state.

@Turtle, @zeebe,
As to the question of becoming a beta-tester, with all due respect, I learned the hard way not to ever again install beta versions, or else, suffer from weeks or months of wasted time trying to clean up my computer from damage done by a buggy software.

I pay for the software and I expect it to work as advertised (not necessarily on your computer but surely, on mine). I understand that the RealMac Software is a tiny company without resources of such companies as Apple or Adobe. But at some point, you have to bite the bullet and start hiring more staff for testing and de-bugging. Otherwise, you can not escape the image of an amateur operation.

I have on my computer some wonderful programs from extremely small developers who work incessantly on improving their apps and those apps just work on my computer, even though I have reason to believe that their computers and configurations are very different from mine. They rely less on generic instructional videos and more on their commitment to their customers.

As much as I love this community for the support and responsiveness, I don’t think this has to be or should be the only remedy to all the problems users encounter in the course of their daily use of RapidWeaver. Or, as much as I would like to send nothing but love to its developers, sometimes working with RW makes me wanna scream in frustration. End of rant…


(Robert Ziebol 🖖🏼) #13

Fair enough, but other than coming on the forums and complaining, just wondering, do you send it crash reports, have you sent in your project files that cause issue. Sounds like you have multiple machines, are you using the same documents between machines, if so, how are you doing that? Does Realmac know how you are doing that?? Trust me, not trying to say you are doing anything wrong, but, other than complaining on the forums, are you doing anything to correct the issue?


(Rob D) #14

Yes, zeebe, I do send reports if I can, but sometimes I have to force-quit RW, or its Crash Reporter itself does not function. When problems are small enough, I try to ignore them. And sometimes I start discussions to find solutions.

My main computer is a MacPro. I keep a MacBook Pro only as an emergency backup and as a testing machine for new OS versions. Both machines have the same version of RW with same Preferences and the same set of add-ons. I use RW to build my web site on MacPro and then, periodically, I copy it to my MacBook (of course, I also keep backups with Time Machine).

Yesterday, I copied my new version of RW project file to the MacBook, made a minor change, saved it and realized that there is no Quick Look preview image in the Finder and in the RW itself. Normally, I would ignore this, but I just read the post by someone else and I just added my comment to it.


(Menno) #15

Just a thought:
Do you have no QL-preview at all or just a generic “LEGO-blocks” preview?
If the latter is true, you use the Stacks-plugin and have the Homepage Preview in Finder in the Stacks preferences unchecked on that machine.
That setting overrules the RW settings even if your homepage is non-stacks page.

Menno.


(Rob D) #16

Hi, @Macmenno,
Thank you! Indeed, you were right. I had identical settings in RapidWeaver’s Preferences, but I forgot to change preferences in Stacks. This is what the project icon looked like in Finder before:


After I corrected Stacks’ Preferences, the Quick Look preview shows up as expected. Thanks again…


(Nik Fletcher) #17

Hi folks

Thanks for your messages. We spend a considerable amount of time building and testing RapidWeaver, and we certainly don’t expect folks to always run a beta - though, if a beta has a specific fix for a customer issue, we typically ask them to try the beta and confirm if the issue they’ve reported is resolved.

The changes between 6.3.6 and 6.3.7 are small ones, and related to specific areas of the app (as noted in the release notes), so while I’m surprised that you’re experiencing new issues specifically with this release, we’re receiving any crash logs you send, and we use these to constantly improve things.

If you’ve got a Quick Look issue, and have a project file we can take a look at, please send us a copy (normally a copy of the project file with just the homepage in it would work, along with all the stacks used). We re-wrote the Quick Look generation in 6.3.6, specifically to address the blank thumbnail issue with larger, more complex, webpages - and would love to make sure future versions of RapidWeaver continue to make things even better.

Thanks!

—Nik


(Butternut Squash) #18

ONE

Not unique to 6.3.7 on my computer (this has been happening with every version of the software relative to Stacks 3), the Stacks Update panel crashes almost consistently. Mysteriously, the worst culprits seem to be the Foundation Pack Add-ons 1 + 2. The only time I can circumvent the crashing, and this is nevertheless rare, is by closing the file that I am working on, opening a brand new empty file, running the Search for updates, and hoping that those particular Workman stacks do not show up.

TWO

Upgraded to 6.3.7 over the weekend. Noticed immediately that while text showed up in Preview, images did not.

THREE

After upgrading to 6.3.7, a totally bizarre upgrade incident with a Stacks alert. The following is a message that I sent to YourHead support, but have not yet heard back:

So this is pretty weird:

Received an alert from within RW to upgrade Stacks 3. Clicked on the update button, the plugin downloaded, and the program quit.

RW didn’t launch again by itself, and so I opened it manually. But there was no Stacks page available.

I then proceeded to download Stacks 3 from your website, but it turns out not to be the latest version. I installed it anyway, but was informed that there was a newer version already installed and that I would effectively be downgrading. Perhaps there was a newer version installed, but it wasn’t available. And so I re-installed the manually downloaded version (3.0.2) that had had been there previously.

I expected, at the very least, to get a new message again advising me to upgrade Stacks. But nothing.

I am obviously a little confused and a little disoriented by this event, and also wondering why your website is not providing the latest version of the software.


(Bob Pruitt) #19

All of this scares the bejeebaz out of me. I’m still running RW 5.3.2 on OS X 10.8.5 and can’t afford to have problems when updating clients sites.

I’ve been thinking about updating to El Capitan, RW 6 and Stacks 3, but these kind of comments make me want to hold off.


(Robert Ziebol 🖖🏼) #20

@Pruitt You have to remember, not everyone is having these issues. I run RapidWeaver on 4 separate computers (3 iMacs and a MacBook Pro) and have had only minimal issues since running RapidWeaver 6.0 betas. My issues were fixed by lowering the consecutive connections on publish.

Also, you can run both RapidWeaver 5 and 6 on the same machine without issue and update a project file, it creates a new one, so you can always use the old one with RW 5. The benefits heavily out weigh the risks since you can always go back to RW 5 if things do not work for you in 6. I say upgrade.

Note to others, I am not trying to belittle your issues, I understand you are having them, just trying to show people who are scared that they can always go back if something happens.