Text always cebtred


(Hans Volk) #1

Hi. My text is always centered even it is ranged left. Any idea? (f.e. http://www.3e-programm.de/page-2/page-29).THANKS.


(scott williams) #2

I think the short answer is:
your text is in <span> tags instead of <p> (paragraph) tags <span> displays inline by default instead of block.

  1. What stack are you using to insert your text into?
  2. Did you try highlighting the text and select clear formatting, then re-apply
  3. your headings and body content should be in separate stacks.

(Hans Volk) #3

Thanks for your fast answer.

  1. I use the normal BASIC TEXT stack.
  2. YES, but still centered
  3. Sorry, I do not understand this.

THANKS

Hans


(scott williams) #4
  1. To do things correctly;
    Each heading should be in its own stack, also each paragraph should be in its own stack.

You might also consider getting/using a set of header and paragraph stacks. This will get you proper HTML markup and greatly help your page structure and seo. It will also make your life much easier when it comes to designing your page.

Bigwhiteduck.com has some great ones and it is donationware


(Rob Beattie) #5

Looks like you’re using the Legacy theme?

There’s an option in the Style Options to set main content to Left Align. Otherwise, the theme will always try and centre your text.

Rob


(Hans Volk) #6

Thanks Rob! I found the option: Main Content left align - and when I click it changes the text really. SUPER. BUT only the first one. Text on extra content fields do not change. Any idea here as well?

THANKS so much

Hans


(Rob Beattie) #7

So you want the text like this?


(Hans Volk) #8

Yes, I want to have it like this.


(Rob Beattie) #9

Well, I can work out how to do it via the inspector in Google Chrome but it’s harder for me - my CSS isn’t very sophisticated - to work out exactly which element needs to be targeted. Can you tell me which extra content container you’re using? I need the number.

Thanks

Rob


(scott williams) #10

if you want to target all of them, try this:

#ecwrap {
text-align:left !important;
}

put it in the page CSS or if you want site wide in the site wide code CSS area.


(Hans Volk) #11

THANK you so much for your help