Text editors blank

Hi everyone,

I am trying to modify an html file on my host server with a text editor but both BBEdit and TextWrangler just show blank documents.

I have tried different documents from the server, and they show the contents using ‘Open with …’ TextEdit, or Safari, but they will not display anything (but the number of lines in each document) in either of my text editors.

Any advice?

I’ve found that Sublime Text will open just about anything. It’s free to try as well.



BBEdit should have no problem opening up an HTML document, that’s what it was made for.

  • Does the page display okay on the server?
  • How did you get the page from the server to your Mac?
  • Did you by chance open the file with any other app like TextEdit first?

Perhaps a URL to the page on the server would help you get help.

Thank you for the thoughts.

It is every page I try to open from the server. I FTP in with CyberDuck, and navigate to a file, select “Edit with…” BBEdit, and while it shows the number of lines in the document, no text appears in those lines.

An example is https://www.15wingfellowship.com/gallery.html which displays fine on the web, and evidently has 238 lines to the document, but none show.

(I have ‘highlighted’ some of the non-text in the image to show you.)

A different document from the server will show a different number of lines, but still no text.

I always try BBEdit first, and then TextWrangler, but it does the same thing, shows line numbers but no content.

I also downloaded the document to my Mac using ‘Download to…’ and opened the file by dragging it onto the BBEdit icon, same deal, different number of blank lines.

Thank you @Rob Beattie,

That is very interesting. Sublime opened it. (Sorry I should have tried that first, I read my emails in reverse order … I was so excited to see a reply I did not notice there was an older one. :D)

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.