Links Don't Work in Default Text Stack with Shift Theme


(Adam Olson) #1

I am not able to get links to work Comtion (Command+Option (⌥)) + a on selected text. They show up blue in the stack but when previewed it doesn’t work. They are not in any other stack and I went through every other theme and the only one that it worked in was the blank theme.


(Vitor Costa) #2

Hello Adam,
Just tried myself and I can’t replicate your issue, everything is good with the Shift Theme.

See it here: http://d.pr/v/1dNzh


(Adam Olson) #3

Thank you after a few days of messing around with things I found out what was causing the problem, it was the text I was copying and pasting from Scrivener. I didn’t realize stacks had it’s own key command to clear the formatting of the text. Once I did that and selected in the text box I was able to adjust the settings to what I needed. The other thing I had forgotten that when you select the text stack the inspector settings are different then when you go into the text in the stack. I was messing with all the HTML and font settings in the stack settings at the bottom of the page to no avail. That makes sense why it didn’t work in other themes ether. I guess choosing the blank theme strips away any extra formatting code or something? Not sure why that worked.

I could see what code to remove inspecting it but still trying to get my head wrapped around how to remove code generated by RapidWeaver and what is the source of the compiled code. Thank you for your help, always helpful to know when it is working for others, it at least keeps me looking.


(Isaiah Carew) #4

Just to clarify…

Stacks had it’s own key command to clear the formatting of the text

this is actually a feature of RapidWeaver. it works on every page, not just Stacks.

I could see what code to remove inspecting it but still trying to get my head wrapped around how to remove code generated by RapidWeaver and what is the source of the compiled code. Thank you for your help, always helpful to know when it is working for others, it at least keeps me looking.

Jumping to a blank theme, or even just switching themes is a good way to see what content comes from Stacks and what comes from the theme. But here’s the techy info for the curious:

Stacks adds two css files in the head:

<link rel='stylesheet' type='text/css' media='all' href='files/stacks.css' />
<link rel='stylesheet' type='text/css' media='all' href='files/stacks_page_page0.css' />

The first is site-wide css. The second is css specific to this page. Keeping those separate means the bulk of CSS for stacks is cached when the visitor hits the first page.

If you enable the comments (in the Stacks Preferences window under the HTML tab) stacks will begin its body content with:

<!-- Stacks v3.2.2 (3843) -->

and end it with:

<!-- End of Stacks Content -->

Everything in between comes from Stacks.

Those are the only things Stacks adds to the page by default. However other 3rd party stacks can request more: javascript, jQuery, other files, libraries, and php. Discussion of those things is a lot longer and more complicated but you can find more detail about it in the Stacks API if you’re curious: http://api.yourhead.com

Isaiah


(Brian LaPan) #5

Good rule of thumb when pasting text from ANYTHING but a plain text editor (meaning anything with advanced formatting) is to Paste & Match Style - then you can adjust as necessary.

For Word docs, I use http://markitdown.medusis.com/ to convert some docs.


(Adam Olson) #6

No doubt that has bit me before in other applications, it just looked like there was nothing there the way it pasted into the text stack but clearly not so when it published. Just my ignorance of what is being done by the theme and how code is generated in RapidWeaver. I have used “Get Plain Text” in the past and have started using it again.[quote=“isaiah, post:4, topic:9556”]
this is actually a feature of RapidWeaver. it works on every page, not just Stacks.
[/quote]

I see that now in the Format menu, kudos to you for also putting it in your Stacks Preferences “Shortcuts” tab and bringing it to my attention.

Thanks Isaiah for all the info very helpful.


(Brian LaPan) #7

I never heard of that app so thanks for that mention. I’m going to give that a try, too.


(Adam Olson) #8

Get Plain Text is kind of nice because you can turn it on to always strip out formatting if you are doing a lot of copy and paste or run a key command to clear the formatting of the clipboard when needed.