Theme Not Found on RapidWeaver 7


(Kathy) #1

Hey guys!

So, long story short, someone created our website for us and now it is up to me to keep it up to date and looking fantastic. I purchased RapidWeaver 7 on MacBook Pro and went to put our already created site in and get the error message:

“Project Theme is Missing: The theme that this document uses is missing. If you open this project, RapidWeaver will apply the Offroad theme.”

Obviously I don’t want that to happen, as we have worked very hard on our digital marketing campaign and I would never want to mess up our website!

Any help would be greatly appreciated!

Thanks so much!


(Mathew Mitchell) #2

Unfortunately the information you are providing is too vague. Can you ask the person who created the website:

  • what theme they used?
  • if they used Stacks (answer is probably yes)?
  • what specific stacks they used?

… or put differently … the person who created the website probably invested in a number of extra tools that work alongside Rapidweave and without those extra tools you can’t easily tinker with your website. It may also mean spending a fair amount more money (but that’s only a guess on my part). In general I advise folks to consider that RapidWeaver “really” costs about $250 to $300 to purchase all the various optional tools that they may want to use. But $99 for RapidWeaver, then $49 for Stacks are simply the beginning.

… of course I don’t know the details in your case. If you provided a URL to your current website others may be able to provide a better estimate of what tools/themes were used.


(Jonathan Spencer) #3

WeaverDetect can find out what theme was used, just add it to our favourite bar and go to your site and click on the WeaverDetect link. It finds the theme but misses a lot of stacks I use.

http://weaveraddons.com/utilities/weaverdetect/

Chances are, like Mathew has already said, you will be spending a few more $$$ to edit the site. The next version of Stacks 3 has a feature to tell you what stacks are missing which would be helpful to you when it comes out.


(Greg Schneck) #4

The person who built the site for you needs to give you the RapidWeaver project files if he/she has not already done so. Then, in addition to tha,t you need to get a list of the 3rd party add-ons he/she used and you need to obtain them so you can add them to your RW app.


(Raimo Karhunen) #5

I just upgraded to a new computer and had the same issue, some of my themes (and stacks) not being “found” even though they were clearly in the Themes/Stacks folder. I finally tracked the issue down to how I was downloading them.

  • If I download them in any format except for .zip, they will not be recognized by Rapidweaver.

Try downloading them that way, open the zip file on your computer containing the theme/stack and then load them into Rapidweaver


(Kathy) #6

Thanks for all the help!

I was able to get it to open with the theme and stacks. The issue I am having now is that it looks like the files that were saved on the work computer were saved before the website was updated because it has old information on it that is no longer on our website. I am hesitant to do anything because I don’t want to change all the updates that were made before the website came into my hands.


(Peter Lokker) #7

I seem to have the same problem; after clicking on my project-file Rapidweaver (7) responds:
"The (null) theme that this document uses is missing. If you open this project, RapidWeaver will apply the Offroad theme. Are you sure you still want to open this project?"
I wanted to, so I clicked on “Apply Theme and open” but nothing happened. The spooky thing is that all themes, including the used “CADiamond” and Offroad are on my Mac and when I start a new website I can use these and other themes and stacks!

This problem started today after I had set up my new iMac a few weeks ago because my old iMac had crashed. Today I tried to fire up Rapidweaver (7) to edit this website. (Everything had been restored with Timemachine).

The silly thing is that I can build new websites with all themes and stacks, and CADiamond and Offroad work perfectly. Rapidweaver does find and recognise all themes and stacks but only some of my websites refuse to open, not even with the offroad-theme or whatever. Other ones with the same age, are fine…

I really hope anyone can help me out, thank you very much in advantage!

Peter

[edit Peter] I just put back an older copy of the two project-files that would not open… PROBLEM SOLVED so the problem must have been damaged files.