Top Bar in Foundation-Change Order and excluding pages from Menu


Still a newbie to RW and Foundation. Liking it a lot.

I am coming over from Adobe Muse. I am using RW8 on a MacBook pro. I have Stacks and Foundation. My initial goal is to replicate a simple site that I created in Muse. I watched Joe’s excellent 3-part tutorial on Foundation and have a grasp of how it works. But I’ve run into an issue that is baffling me and also leads to a second question:

1- I have created my first page with a top bar and will be saving it’s core as partials and one complete partial as well to be a master page. As I recreate the above-mentioned site, I am adding new pages to get to the 6 main pages that currently sit in the menu bar. I plan to add a 7th (Contact) page. What I’ve discovered is that, even though I am adding the pages in the order I will want them to appear on the bar, the most recent page I added did not go into the lowest position on the left Inspector Bar and I see no way to change the order. That is being reflected in the Top Bar and suddenly a page that should be in the 5th position on the nav bar is in the 2nd position. I’m sure there is a way to change the sequence of pages on the top bar, but I can’t find it.

2- I will also want to create child-pages that will not appear on the nav bar at all. It appears that when I create a new page it automatically shows up in the Top Bar. Is there a setting that allows us to create a page and exclude it from the menu on the Top Bar?

Thanks again very much for any help!

You can drag them in the pages bar.
There is a tick in the page inspector UI to show/not show in nav
To create child pages that appear in a drop down nav from the parent page drag the page “over” the parent page in the pages bar, it will indent slightly and go below the parent.


The Pages bar on the left? I tried dragging and nothing happens. or are you referring to something else?

Also, I’m not seeing anything to tick off in inspector.

Reordering pages: Yes, you should be able to drag a page name in the left sidebar to reorder it. Just click (and hold) on a page name and drag it up or down. As you move it, you should get a line showing where it will be moved to.

In the right-hand sidebar, you need to select the first “tab” which contains the page’s General Settings. Currently, you are on the stack’s setting “tab”. On the first tab is the “Show in navigation” checkbox.

You may want to look at the other panels in the right sidebar so you know what’s there.


Found it! Yes, I do need to more carefully examine the panels.

Oddly though, while I know what you are referring to with the click and drag and the the line, it is as though the pages are locked in position. I try clicking on the icon on the left to drag, the blue dot on the right to drag, and the name. Only reaction is when I click on the name, it highlights in blue to be renamed.

does this help:

Just click and drag…for subs…drag over a main item…like you see in my “In the News” items.

1 Like

The show in Navigation, Yes thank you. But I still can’t seem to move pages.

As mentioned elsewhere, I did find the tick box to have the page not show in the Nav bar, thank you.

However, and this is especially frustrating, I can’t seem to click and drag the pages in the left column.

When I create the page, I am clicking on the + and then on Stacks. I then try to click ‘n’ drag but nothing grabs. If I slide over the name, that highlights to change the name, but that is the only reaction I get. If, after clicking (and holding) I try to drag up over another page, I simply change the highlighting in grey of one page to the one I’ve slid over. nothing else.

Is it possible there is a setting I’m missing?

Just for the heck of it, I saved the file, shut down RW8 and restarted it. Nothing changed.

I must be missing something! (It’s not like I’m new to computing-click and drag is common a thing…!)

thanks for your thoughts.


I usually click (and hold) on the icon next to the page name. I can then drag and drop. You do need to position the page between two existing pages (or above/below the first/last pages). You’ll see a line appear between them. If you hover over another page name and release it creates a sub-page.

I’ve used RW since v3 and never saw this not work, and I don’t believe there is any setting in RW to enable/disable reordering pages.

I would create a new project, add a few stack pages (they can be blank) and see if you can reorder them.

I’m sure this is frustrating, as it sounds like you’re understanding what to do and it really is as simple as you’d expect it to be.

okay try this:
click once (and release) to select the page
click the icon & hold
drag to new position & release

1 Like

nope. same thing. they appear to be locked.


I’m not aware of anyway to “lock a page position” You can even drag them if they are draft or set to not show in nav. Sorry, I don’t know what eles to tell you. Maybe contact RealMac support and give them all of your system details and RW software details and explain whats going on.

1 Like

I tried finding a link to support and the only thing I found was for sales… I will look further. Thank you very much!

Very strange… can you drag stacks on the page (in edit mode)? can you drag files in finder?
Asking because maybe there is something in system pref’s accessibility settings causing issues. - That’s about all I can think of.

Did you try restarting your Mac?

I can indeed click and drag the stacks with no problem at all. Dragging files in Finder works just fine. I didn’t restart the mac, so I guess I should try that, but it’s really only that column that is unresponsive.

I sent off a not to that support email and we’ll see if they have any thoughts.

thanks again for your help.

Ive never see or even heard of this issue in all the years i’ve been using RW. I’m curious, can you right click on a page and get the context menu?

Show Inspector
and I just rebooted, NOT restarted.
so, URK!
I’m stepping away and going out into the beastly NY summer for a little while and then I’ll retackle this. It will be useless if I can’t solve this.

Okay, you want weird? I’ll give you weird. I figured I tried everything else, why not bypass the trackpad and try using a mouse? Nothing else worked and when all else fails, try the ridiculous.

So I did.

and it worked!!!

for whatever reason, there is something about that particular click and drag that doesn’t play well with the trackpad, but works just fine with a mouse! I use a mouse on my desktop machines, but never on the Powerbook. Well, now I’ve got to keep one handy.

Oh, so weird!

I still have no idea why- I played with all of the settings for the on-board track pad, but nothing worked and it’s only for that one aspect.

So, thanks for any weird deliberating you might’ve done. We don’t know the reason, but we do know the solution.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.