TotalCMS and www

Can anyone help me? The site I am building is referenced everywhere by However when you search for Dr Shen Tai Chi UK in Google it directs to as a consequence the TotalCMS admin pages will not load.

My Sitemap.xml has www. everywhere but if I go to the Google Search Console and goto Links it shows the top links for and says the pages are referenced by the index.php files on the site. However these index.php files have www.

I am very confused, I hope someone can help.

Having both www and non-www being allowed isn’t good practice.

You can get dinged for duplicate content so your page’s SERP ranking can get hurt.

You see and HTTP:// can be two totally different sites running on two different servers in different parts of the world. So is the domain name and www is considered a subdomain of

First, you need to pick the survivor you want to keep. Looks like you registered one with www, but search engines are pointing to the other. If it’s not difficult to change the registration, I’d keep what search engines are using or you might take a hit, but it’s up to you. You might have advertised with one or the other.

Once you choose the one you want to keep www or non-www then you need to redirect to the one you want to keep.

If you are using Apache then you can have a look here.

Thanks for this, I will do as you suggest. Thanks again.

Looking at my .htaccess file I already have similar lines? Can you help by telling me how to change this?

RewriteEngine On
RewriteBase /

RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R,L]

RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

Many thanks

I should add I don’t want the www. as Google search does not want it - so I want to redirect www. to non-www.

OK, sorry. I figured it out and now my site is just and the .htacccess redirect works fine. But when I try to log into a TotalCMS page to edit it I get a message saying "The Web Address configured in your RapidWeaver project ( does not match the published domain in your browser ( "

In my general settings and publishing settings I have changed the url to non www.

What am I not doing?

You’ll probably need to change the totalCMS license. I don’t know how you do that as I never used it.

The first part of the code you have kind of forces HTTPS (doesn’t do an RC so you’ll end up with a 302[temporary]) .

The second part

RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

I’m not sure what or why you are doing that. Without knowing why you’re doing this i can’t say for sure.

This will eliminate the www and force HTTPS:

#  Force HTTPS and Remove WWW (this is a comment)
RewriteEngine On
RewriteCond %{HTTPS} off [OR]
RewriteCond %{HTTP_HOST} ^www\. [NC]
RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
RewriteRule ^ https://%1%{REQUEST_URI} [L,NE,R=301]

You can add that second part after the above.

Thanks again for all your help.

Total CMS licenses are always associated with the root domain. Therefore, it does not matter if you have www or not for the license.

However in order for the admin area to work properly, you need to make sure that the url setup in your project file matches the url you use in the browser.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.