Trying to enter Meta Data in Rapidweaver?


(Kalikoweo) #1

In the page inspector for each page of my site (not published yet because of this issue), when I try to enter info into the Meta Data section I start at index.html (Home page) and work my way down naming each Meta Data field for each page like I want as follows - Browser Title is not the issue:

Home page:
Folder: my page (by default)
Filename: index.html

About:
Folder: /
Filename: about.html

Gallery:
Folder:/
Filename: gallery.html

Gallery2:
Folder:/gallery
Filename: gallery2.html

Gallery3:
Folder:/gallery
Filename: gallery3.html

Exhibitions:
Folder:/
Filename: exhibitions.hmtl

Contact:
Folder:/
Filename: contact.php

Links:
Folder:/
Filename: links.html

When I name all of this I either get an error message OR the file names revert to either the previously named page file or something else.
For example I just finished naming the links page and clicked on Contact to double check it and on the contact meta data info it says “links.php”, "exhibitions.php or another page name. Same thing happens on the index.html pages

I have tried all of the above without the (/) in Folder field and instead entered just the folder name: ie - "about"
I have tried all of the above with “Tidy Links” in Advanced settings enabled with no luck.

Please help, I am at my wits end on this and have never had this issue before when using Rapidweaver. I recently upgraded to Rapidweaver 7 and this is the first time this has happened. Also tried uninstalling and reinstalling Rapidweaver 7. No luck.
Any help or advice greatly appreciated.
Sorry for the long post.


(Robert Ziebol 🖖🏼) #2

Here is what I would do, it will make your site much cleaner looking too, and easier for people to navigate to. I am going to copy and paste your list below but change stuff:

Home page:
Folder: my page (by default)
Filename: index.html

About:
Folder: /about
Filename: index.html

Gallery:
Folder: /gallery
Filename: index.html

Gallery2:
Folder:/gallery-2
Filename: index.html

Gallery3:
Folder:/gallery-3
Filename: index.html

Exhibitions:
Folder:/exhibitions
Filename: index.hmtl

Contact:
Folder:/contact
Filename: index.php

Links:
Folder:/links
Filename: index.html

Not sure if it will solve your issue, but it will make your site much more tidy both on the web and on the server. Be sure you have Tidy Links on in the Advanced settings. On the server it will look like this


(Jason Bostick) #3

This isn’t necessarily answering your issue but, further to Robb’s post, the “Tidy Links” options ONLY works when your pages are named as index.html or index.php (as Robb has done).


(Kalikoweo) #4

thank you for that. I have previously tried entering everything like that working my way from the index down.
Just did it again exactly how suggested.
Here is what displays when I go back to the top and double check everything:

Home:
Folder: my-page (default)
Filename: index.html

About:
Folder: /about
Filename: gallery.html

Gallery:
Folder: gallery
Filename: index.html

Gallery2:
Folder:/gallery
Filename: index.html

Gallery3:
Folder: /gallery-3
Filename: gallery2.html

Exhibitions:
Folder: exhibitions
Filename: index.html

Contact:
Folder: /exhibitions
Filename: index.php

Links:
Folder: /contact
Filename: index.html

It all changed like that on its own. Thus my problem. I am at a loss here. Is it the app?
Is it something to do with my pages?
Contacted Realmac support but still waiting for a response.

Any ideas?


(Kalikoweo) #5

Tried another uninstall of the app, rebooted, tried again and it seems it worked.
Glitch?
Anyway thank you so very much for the help guys, really appreciate it!