Unexpected Project File size

My project size went from 26Mb to 134.7 Mb. I made a small change and then went to publish. It says it couldn’t upload to FTP server. It’s now trying to publish 1744 files when it used to be in the 6-700 file range.

Test connection works successfully.

I’ve tried to re-publish another small website and it won’t publish either.

I’m stumped…

I’m following this post. I can’t put my finger on a pattern, but I’ve certainly seen a situation where I added @joeworkman’s Video Wall stack to test it on a scratchpad page, went to republish, saw that it had added 2,000+ files, cancelled publishing, deleted the Video Wall stack from my project, republished, and Stacks still tried to publish 2,000+ files.

Something’s weird.

Make sure you have the latest version of Video Wall. There was an issue with one version that did result in a huge number of files being uploaded.

Joe fixed that, but Video Wall does require a whole load of API files to be uploaded the forst time it’s published - around 2,600 tiny files.

This from Joe when I asked the question.

Its very hard for me to attempt to know which of those files I need in order to connect to YouTube APIs.
And trying to individually manage them is not possible.
These files will not upload every time

Thanks Gary. I get that it’s a complex stack, and I’m proper OCD about running update checks multiple times a day, so I have the latest versions of everything. Video Wall is a great stack, and it just highlighted this issue for me, because it does require so many files - it made the problem much more noticeable.

The issue is very much that having removed the stack from the project, it STILL tried to upload 2,000+ files, even after shutting RW down.

I have no idea whether this is a Stacks problem, or RW.

Pearson @pearson4, are you also using the Video Wall stack?

Adam @jacksona, sounds like you can easily recreate the problem, you might want to get a project file over to @isaiah so he can have a look.

1 Like

No, I’m not using Video Wall. You think I should delete RW and re-install? I’d hate to loose everything…

I wouldn’t, at least not yet. Sounds like we have two different problems then.

Let’s get back to @pearson4 the OP problem.

First thing is that you need to get publishing working. The fact that the project file size got larger or RW wants to publish more files then you think it should have is irrelevant if you can’t publish even a “smaller” site.

Once you have the publishing working then if the file count or project file size is still an issue then address that secondly.

Publishing problems usually happens when something has changed on your computer (like updating the OS or RW) or changes made by the hosting company.

Without more information from you it’s hard to figure out what’s happening.

  • name of hosting company
  • screenshots of the error messages when you publish
  • screenshot of your publishing settings (obscure the password)

This would be a good starting point in getting you back up.

Doug, thanks for the help.

I am using Chillidog Hosting and I have not updated my OS system (as far as I know) and I’m using Sierra 10.12.6. It’s old but a good one…lol

I think the Stacks was updated withing the last 2 weeks and since that update, I think I was able to publish the larger site. Then I made a change on the MegaMenu and then it went south (That’s my best guess).

Here is the screen show of the large site:


Good news is, I am able to cancel the publishing for the Large Site without the RW Freezing up now.

I was also able to PUBLISH my smaller site.
Here are those settings:

Standing by to get back to normal.

Now the smaller site publishes okay.

I don’t use chilidog and I can’t find any public knowledge base. Not sure what the path should be for the second site.

The one that works uses public_html, the one that doesn’t uses a different path.

I’m assuming that the test button works on the site that’s not working.

You might want to contact chilidog support and wait for a reply, unless someone else can who is familiar with their setup can help.

Yes, the smaller, second site (custom-floor-drains.com), does publish correctly. It is also the Main Account with Chillidog Hosting (https://chillidoghosting.com/) and the larger site (customdrains.com) is a sub-site (additional domain on the main account). I have several others domains under the “smaller, second site”

I have always used the same Path for the larger site, customdrains.com/. I’ll check with Chillidog, but I’m confident that I’ve been using the correct path(s).

I think I might create a “new” mega menu and see if that changes things.

You might try publishing to a local folder. That would tell us if RW is having issues generating the pages or if its is an FTP problem.

I’ve been trying to publish to a local folder, no success. I’ve tried downloading NAMO and it tells me I can’t open because of security settings.

Hate to keep asking, more help please.

When you say NAMO are you talking about the local DNS for MAMP and MAMP PRO?

Not sure what you are doing with NAMO?
So can you publish to a local folder from RapidWeafver without error?

So if you can’t publish to a local folder without errors, then there is something wrong with one or more of the pages. The ftp settings won’t make any difference. You need to figure out what page or pages might be causing the issue. It could be a resource that isn’t right. It’s a process of elimination.

If you can publish to a local folder without any errors in RapidWeaver, then until you get the RW publish working, you can try to use a stand-alone FTP app like transmit(paid) or FileZilla(free) to publish the site outside of RapidWeaver.

That will get you working until you get RW publishing going.

As for NAMO, if you have been able to publish the site locally and want to view it, you might want MAMP. NAMO is a local DNS server that allows you to just use a host name to view local web sites on your Mac.

1 Like

Well, I’m not having any luck with publishing locally. Can’t figure out how to install MAMP, all I get is a lot of tar.gz files. Clicked autoconfig 2.68, then clicked configure (exec)…Nothing.

I guess I’ll have to keep eliminating things to find the culprit.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.