RapidWeaver 8.4.1 crashing on save

Hi all,

I am having an issue that I’m hopeful that someone can help me with. I’ve reached out to RapidWeaver Support, and after 2.5 weeks it has not been resolved.

Any time that I go to save a project, RapidWeaver crashes. I can click Save As, rename it, and pressing OK…it crashes. I disable plug ins. Crashes. Remove themes. Crashes.

I am dead in the water. Can someone please assist me?

Mac 10.15.1, RapidWeaver 8.4.1
Disabled plugins by pressing Option/Alt Key - same issue
Created new project with no custom themes and no stacks - same issue

Might be worth downgrading to 8.3 via the Version History page - I know it’s a different situation, but I had a problem with previews hanging, which this fixed (8.4 didn’t make a difference).

Might help, might not!

Worth a try though, as the 8.4.1 and 8.3 versions can coexist…

Adam.

Thanks @jacksona

Tried that - same issue.

When did the problem start? Was it following upgrading RW or Catalina?
I will guess Catalina. It would be a chore to use Time Machine to return everything back…
I kept my old Mojave OS on an external HD for just this situation, so I could use programs while debugging Catalina if problems occured.
I would suggest re-installing Mojave and RW on a bootable external until support/you resolve this.
Again, if possible.

@curiouschuck It started before I upgraded to Catalina, so I’m lucky that I know that isn’t the issue.

Thank you for the suggestion.

Does it happen with a single project or every project?

Have you tried a new project with just a single page?

@teefers - every project. new projects, single pages, existing. every file that is opened crashes.

I did revert to RW7 and having no issues on Catalina.

1 Like

Wow,

I was going to suggest you reinstall RW8 but since you tried an 8.3 version, I don’t think that would help.

Someone from RealMac (@dan, @tpbradley, @Aaron, @LaPan) will need to have a look at the crash report.

I have just developed the same problem. Had been using 8.4.1 with catalina successfully. Any updates ?

I have tried to open a backup project that was working fine and same issue. Dead in the water as working older backup now not working

What is your setup? Are you using any ancillary apps like DropBox? Or iCloud?
I have a fairly large drive, and everything happens ‘locally’.
Keeping it simple.
Also, I’ll just leave this here :wink:

Hi Chuck, I keep everything local on my desktop and only put zipped backups onto cloud storage so it isn’t that. (had that problem 8 years ago with RW and learned my lesson then). Have sent the crash report and problem description to RW support but no reply… Will give em 24 hours and chase.

1 Like

have emailed my issue to support@realmacsoftware.com two days ago and no reply or acknowledgement

Can anyone make any sense of the crash report?

Process: RapidWeaver 8 [4104]
Path: /Applications/RapidWeaver 8 (restored).app/Contents/MacOS/RapidWeaver 8
Identifier: com.realmacsoftware.rapidweaver8
Version: 8.4.1 (20817)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: RapidWeaver 8 [4104]
User ID: 501

Date/Time: 2019-11-25 15:20:22.100 +0000
OS Version: Mac OS X 10.15.1 (19B88)
Report Version: 12
Anonymous UUID: 63EB0B92-62F9-C9F0-E6E6-6ED6F65F0576

Time Awake Since Boot: 7600 seconds

System Integrity Protection: enabled

Crashed Thread: 10 Dispatch queue: com.apple.root.default-qos

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [4104]

Application Specific Information:
Performing @selector(saveDocument:) from sender NSMenuItem 0x600003d2de30

I have been battling stopping RW 8.4.1 from crashing on save under OS 10.15.1 and have made some progress. I removed ALL stack add ons and still crashes on save. The source of the crashes seem to be plug ins, specifically Formloom 4 and Collage2.

I upgraded Formloom from 4.0.11 to .12 and this seems to have stopped formloom based crashes but with Collage2 2.5.0 latest version crashes regularly. I will be removing all pages that use Collage 2.

I was somewhat puzzled that when I click Check for Updates within the Stacks library it showed all stacks up to date, however the PLUG IN Formloom was an older version. Is there an obvious way to check latest version for plug ins?

Replied to your identical post:

I have the same problem except just with ONE project. Other ones are fine. I didn’t change anything in the file except editing a few words of text on one stacks page. VERY annoying and a huge problem since there is no way to edit the site any more. Publishing also causes an instant crash. Save As… = instant crash.

Multiple fast undo also crashing the app. I am changing colors or some padding then making Undo multiple times and app immediately crashing.

Are you using stacks 4?

There are a couple open tickets withs stacks 4 and undo. Don’t know if it’s the same problem.

Stacks 4 installed but I am using generally Foundry. I must test it after uninstall the Stacks 4 than. I’ll let you know it is related or not.

Stacks is needed to use Foundry. He just wanted to know which version you were using. As he mentioned, they do know about the issue.

2 Likes

You are totally right. Thanks to warning. I am using v4.0.3.