Uploading problem with one.com - "The requested URL /index.php was not found on this server."


(Wendy) #1

Hi does anyone have any experience of this?
I have redesigned a website for a client and had no problem uploading to a test site etc. Now I want to replace their old site on One.com and after having deleted all the old files uploaded the new website from Rapidweaver (and tried with Yummy FTP) and I get an error message
"The requested URL /index.php was not found on this server."
The old site had both index.html and index.php files…of course Rapidweaver only has one .html file.

Have pretty much tried everything - any ideas??? Tried One.com support - useless, didn’t even know about rapidweaver.
Thanks anyone…


(scott williams) #2

What is the url?


(Wendy) #3

http://www.cjm-digitalservices.co.uk but I have put the old website back…


(Doug Bennett) #4

It’s going to be difficult for folks to help out after you restored the site back to what it was before.
I understand that it’s a live production site, and you don’t want to leave it broken for very long.
Usually, web severs will look for an index.html, if not found will look for an index.php and then an index.cgi. This order is configured by the server. If none are found then you should get a 404 error (not found) or an index listing of the root directory, all through the index listing is usually blocked for security.
You’re error message in your first post suggested that “something” is looking for an /index.php file not just the generic URL.
It’s not clear what or where you’re getting the message, was it yummy FTP, RapidWeaver publishing, or when you tried to access the site? What was the complete message?
Some screen shots of the message, publishing settings, directory listings from the published site and any other additional information would help.


(Wendy) #5

I know…but I gave up trying so needed to put back the old one back as obviously is a business site. Was going to have another go tomorrow - the error message is when I have uploaded the new site and is an 404 error plus the message.
The new site only has an index.html…which is in the right place but as you say something is looking for an index.php too - that’s why I am a bit confused!!
Will post more tomorrow -
Thanks for any ideas from anybody…


(Jason Bostick) #6

Just change the settings of the page to php and then delete the html from your server. There are a few stacks that require php (some contact forms, for example).

As for the 404 error, some more detail would help, as Doug suggests.


(Wendy) #7

Hi tried that!! It gave me kind of directory page…no graphics etc…
will try again tomorrow and give more clear info… Didn’t have any problem putting it up as a test site on a free web host site…actually am trying to persuade the client to move to chillidog where all my other sites are hosted…kind of know what I am doing there!!


(Jason Bostick) #8

It sounds like maybe not all files were uploaded. After changing the extension to php, the next thing I’d try is Republish All Files. (You may have done this already as well and I’m misunderstanding the issue). A move to Chillidog is always a good option too :slight_smile:


(Wendy) #9

Hi Jason…think I am going to sleep on it and have another go tomorrow. I also have a feeling there may be some ‘hidden’ files that I have not deleted from the old site??? Just a little thought in the back of my mind.
Think I did a republish…but would be totally ecstatic if they would move to chillidog - Greg is awesome!!
Thanks so much for all the thoughts…


(Dave Farrants) #10

I have 10 sites on one dot com, what I’ve done when uploading a new version of a site is to use an FTP (Yummy) and make a new folder in the root called old_site then drag all the old site files except the google html, bing html, htaccess and cookiechoices files into it, then drag the new files in from a ‘local’ publish. Future revisions are then uploaded direct from RW.


(Wendy) #11

Hi dave…thanks will drill down and look at the old files…but good idea with the new folder old site thing?? I just took them off to a local folder pin my desktop.
Still think there is a rogue file missing or conflicting!!
WE shall see


(Wendy) #12

OK tried that…didn’t help (still same message index.php cant be found…and really cant be bothered wasting more time. Thanks everybody for thoughts.


(Rob Beattie) #13

It’s there if you just complete the URL - http://www.cjm-digitalservices.co.uk/index.php - but the page itself is missing some stuff.

Rob


(Wendy) #14

Hi Rob, that is the old site I keep having to put it back…cannot get the new one to be seen. If I upload the site as is with an index.html in the root then I get the error message "Not Found index.php"
If I change the html to php then I get a kind of ‘directory page’


(system) #15

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.