Vanishing images


(Janet Barrie) #1

I use RW 6.3.3 and Stacks 3. I saved and uploaded my site on 29 Aug absolutely fine, come today and the images have vanished from most of my project (obviously not from the uploaded site!). They have gone from RW’s own ‘right caption’, from the ‘Montage’ stack, from loads of ‘image caption’ stacks (Joe Workman), from the ‘ultimate lightbox’ stack from Weaver Addons. There are just small squares with blue question marks where the pictures ought to be, and it isn’t possible to drop an image onto them, the image doesn’t ‘stick’ so to speak. The only ones which remain are images in Carousel and in the RW blog.

I tried an earlier version saved when I know it was working fine, the images are missing from here too.

Sorry if this is really simple but I just don’t get it.


(Mark Sealey) #2

Janet,

How did you place the images onto your pages at first?

If you dragged-and-dropped them there, then they really ought to be in your Project file. You can discover this by doing as follows:

1 - for safety’s sake make a copy of the Project file in question by right-single-clicking on it in the Finder and selecting ‘Duplicate’, then (re)naming that copy in a way that’s useful/memorable… ‘SAFE_RW6_Project’, or similar; you would later revert to this if things ever went wrong

2 - now single-right-click on the original Project file in the Finder and select ‘Show Package Contents’

3 - open the Pages directory there

4 - navigate to a subdirectory (in that Pages directory) which corresponds to a page for which you know you should have images. Such subdirectories of this ‘Pages’ folder will be entitled ‘nn-name’, where '‘nn’ is a (2-digit) number, ‘01’, ‘02’, ‘03’, ‘04’ etc and ‘name’ is the name of your page, which will be either ‘page1’, ‘page2’, ‘page3’, ‘page4’ or - if you renamed them in the RW6 Inspector such names as ‘home’, ‘contact’, ‘about’ etc

5 - in a page’s folder, you’ll see another subfolder, ‘Data’; open that

6 - do you see files with names which you won’t recognize, but extensions which you will - hopefully .jpg, .png etc. Those are your graphics files on their pages.

Do you see them?

One reason that images may not show up is that you have moved either their originals/sources in the Finder when you have deployed them using RW’s Resources; or you have moved your Project file to another computer which does not have the images on it, or at least not in the same place under those circumstances.

Did you use RW’s Resources to manage images?

Did you do anything else to your RW version, your Stacks installation or your Project file between the last time it worked and today?

Did you also export your project locally?

As a test, can you temporarily make a new page in a new, ‘dummy’, RW project and deploy graphics there?


(Janet Barrie) #3

Hi and many thanks for the reply.
They were dragged and dropped and no, I don’t see them in the folders following your (clear - thanks!) instructions. I only see a ‘contents.plist’ file. I haven’t moved anything on my computer, they are where they were when I first inserted them.

I have had something similar before but that was only in Joe Workman’s image caption stack and whilst it was annoying I could reinsert them. Now its virtually all of them - about 50 or so pictures.

I don’t know what RW Resources is, sorry. I did download Stacks 3 but it has worked fine since then. If I export locally they are not seen there either.

Interestingly since this started, the image of my project on the RW startup screen has changed from an image of my homepage to the stacks logo. I also had a fleeting error message saying that something had gone wrong with stacks and I should rebuilt my library or something, but the stacks all seem to be there so rebuild from what?

I will try a dummy project but it is nearly midnight here. It might not be for a couple of days depending on the day job.

thanks again for your help

Janet


(Mark Sealey) #4

Janet,

So sorry that you’re having this trouble. Others may have ideas - in the coming days, for you.

Otherwise I’d suggest contacting the excellent RealMac support… they may have diagnostics which explain this - not least sending them the project file in question.

Yes, try the new/test/dummy file first when you have time.

You may have some sort of irregularity in your RW installation; or the project file itself - especially since you’ve had error messages.

I doubt it has anything to do with the Stacks you have.

You could also try creating other pages in the troublesome project file and adding graphics to see what happens.

Good luck!


(Isaiah Carew) #5

Since this is an issue in Stacks, he should probably contact us instead. I’d recommend sending the file (zipped) via a dropbox share. If you have an older version of the file from when the problem didn’t exist that would be helpful too.

Isaiah


(Janet Barrie) #6

Hi,

Thanks for the advice. The dummy file seems to work ok but the main one doesn’t…
Isaiah, I’ve sent the files, thanks.

Janet