View Source bug in all versions of RW6


(Michael Forte) #1

Please provide a few details in the following format so we can help you as quickly as possible!

RapidWeaver Version: 6.2.3 (14912)
System Version: 10.10.4
Hardware: MacBook Pro (Retina, 15-inch, Late 2013), 2.6 GHz Intel Core i7 Processor, 1TB SSD Storage, 16GB Memory.

Issue:
This bug has been present in all versions of RW6. When I go to view the code at View->View Source, the code that appears is always offset down the page. See attached image

Expected Result:
The code should line up with line 1

Additional Links:
View Source Bug image


(Mark Sealey) #2

I’ve always seen that too.

Isn’t it supposed to be like that?

If not, how should it appear?

What’s the purpose of the space at the top of the screen?


(Rob D) #3

That space should be filled up by the source code. I have this bug appearing intermittently: sometimes the code takes up the entire window and sometimes is squeezed into a microscopic space in the bottom left corner. In my case, it is even smaller than in the above screenshot.


(Michael Forte) #4

In RW 5 it worked fine. Something broke in RW 6 is all and they need to fix it.


(Mark Sealey) #5

Agreed. Thanks for showing that it was not just me who accepted it that way.


(Brian LaPan) #6

I just tried those steps and it works as it should for me on all my sites. Could you please check and see if this is true for all your projects, old and new? If you don’t have a new one, please create one simple page and take a look for us.


(Mark Sealey) #7

Thanks, LaPan!

Sure enough, when I do as you say, I get the source starting at line 1 at the top.

Maybe it’s just Projects imported from RW5?

For I definitely see it - all the time; so much so that I gave up trying to use it - not least b/c RW is so good at rendering WYSIWYG!


(Pedro Perdomo M.) #8

Is working as expected on my side. Including projects imported from RW5

Best


(Michael Forte) #9

Very strange things here! I just checked a new page and it’s working fine. Then I went and looked at a few other projects that weren’t working and they look ok now as well.
I then went to my original main project that has been giving me this problem every since I went to RW 6 without fail. It still showed the behavior. I then tried a different project with no problem. I finally went back to the original troublemaker and it now works. I’m not sure what to say except that I’ve had this problem for months now and now it seems to have fixed itself ever since I tried to View Source in several different projects.

Maybe the bug was fixed in one of the more recent releases of RW6 and this toggling back and forth cleared it out. I have no explanations and I’ll just keep watching for the behavior to reappear. FYI, since upgrading to RW6 I have been exclusively using the Foundation theme in case that’s a variable in this.


(Michael Forte) #10

Well I continued working more on the site and it happened again on the same project. I went and tried a different project with no problem. Came back to my working project and it’s all messed up with the View Source. I closed the project and reopened it and it’s working again.

What this tells me is something is causing this bug to appear while working in the project but closing and reopening the file “resets” it to a good state.


(Nik Fletcher) #11

Hi Guys

We’re aware of this issue, and investigating. We’ve never been able to reproduce it, which is frustrating, but we’re continuing to look into it!


(Mark Sealey) #12

Thanks, Nik - it’s definitely (been) a problem…


(Nik Fletcher) #13

Thanks for the update. We know what causes the problem to present itself (the OS X auto-layout system). We’re just struggling to reproduce this - due to the way the auto layout system works, we need to inspect what the current window layout is doing behind the scenes in the debugger.

—N


(Michael Forte) #14

At least you have seen it too. Thanks and good luck!


#15

@nikf, all my projects still show this bug.

I created a brand new project with only a styled text page, pasted in some text from a random text generator, chose a built-in theme and its there too.


(Markus Frieauff ) #16

same here. In all projects.


(Nik Fletcher) #17

This isn’t a project-specific issue, it’s due to the OS X Autolayout system. We’re continuing to investigate.

—N