Weirdest of FTP issues following RW8


(LJ) #1

I have published a couple of small RW8 sites with absolutely no issues. Now however, if I try to FTP either of the sites outside of Rapidweaver, I can’t connect - get a password / login error. I generally use Fetch FTP but have also got a colleague to test with Transmit. Both failed.

I have reset passwords and cut/pasted to ensure no typo’s but nothing works - except Rapidweaver ftp which continues to work fine.

I have no issues with any of my RW7 sites - external FTP works fine as does RW publishing. It’s almost as if RW8 puts some kind of ‘you can only ftp with rapidweaver’ block (which I’m sure it doesn’t). Anyone else with new RW8 sites - I’d be interested to hear if your external ftp still works


(Mark Sealey) #2

Could RW be changing the permissions of the parent directory; and/or of the files themselves?

They should be 755; what do you see if you Inspect them in Fetch or Transmit etc?


(Brian LaPan) #3

Try a Keychain repair?


(LJ) #4

Problem is - I can’t get in there to see! Wonder of I can see this through cPanel - where I do have access.


(LJ) #5

Have taken a look at the folders via cPanel>FileManager and most folders are 0755. However, the index file and sitemap are 0644.

Have also noticed that the project, for some reason, has become entirely index.php when the only php page should be the Formloom 3 Contact page. I certainly didn’t change any pages to php. I’m wondering if adding Formloom has changed all pages somehow. Certainly never happened before but I am using a very new release of Formloom - 3.0.11.

All this aside I still cannot understand why I can publish with Rapidweaver ftp no problem but cannot even access the project with anything else.


(LJ) #6

php issue sorted - I used BWD Paragraph Pro with icon lists. the icon lists force php. Still no resolution of ftp access however.


(Mark Sealey) #7

What are the parent directory’s permissions?


(LJ) #8

Thanks guys - somehow this is sorted although I’m still not sure what happened. At various points, Transmit worked and Filezilla didn’t - then the other way around. Fetch never worked at all! Rapidweaver FTP worked all the time. Confess to total confusion!

Terminated both new accounts in WHM and set them up afresh with new passwords & Usernames - now everything works. I’m none the wiser but at least back to work! the only other issue - totally outside of RW, is that I used domain names as used at the registrar for the account instead of our glue records (used for branding) in WHM. Can’t see how this would affect anything but maybe something there was going awry.

Thanks again for your input!


(Thomas Roegner) #9

Hi,
sorry, this is not really a reply - I have the exact problem the other way round - publishing via ftp (Cyberduck) ist easy and flawless - but can’t get the FTP connection working inside RW 8.
But I need this one now because I started Easy_CMS (Joe Workman) and I need a “live” connection to my server within RW to make Easy_CMS pages working.
Sure I can publish via FTP and then put all the text and pics on the site via the CMS login but this is double work…
Dealing in Germany with german providers as Strato, HostEurope, WebGo - none of the connections is working inside RW8.
Any suggestion/solution for that, anyone?
Thanks,
Tom


(Doug Bennett) #10

Without additional information it’s going to be difficult to get help. Just saying “can’t get ftp connection working” doesn’t give much information on what’s happening.

  • What steps have you tried
  • Screenshot of your publishing settings
  • What exactly happens when you hit the test button?
  • If test works what happens when you hit publish?

(Thomas Roegner) #11

Hi Doug,

thanks for trying to help. Was a misunderstandign with my customer who had not set a password for his FTP connection. Got it up and running now, sorry - will check all FTP passwords in future.
Thanks again,
Tom


(system) #12

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.