Stacks problem?


(Phyl) #1

ISO 10.12.6
RW 7.4.1
Stacks 3.5.3

After updating, RW shows that stacks is not currently installed. This may be called extracontent.
I would like to post a blog entry using Rapidblog but I am afraid to publish and lose my entire web site because a stack is not installed.

Please, I need some help.
Thank you


(Robert Ziebol 🖖🏼) #2

Show us a screenshot of the page with the settings, we might be able to tell what stack it is


(Phyl) #3


(Adam Shiver) #4

@sewquilt Looks like you’re missing the ExtraContent stack. Easy enough to re-download and install. You can download it here from the ExtraContent site: http://foss.seydesign.com/?p=ExtraContent


(Phyl) #5

I downloaded extracontent, I tried to follow the instructions for install but I was not successful. I tried to drag/drop extracontents to the home page in multiple places on the page. Nothing worked.

Is there a special place to drag and drop the icon?
What I need to adjust in settings?


(Adam Shiver) #6

ExtraContent is a stack that gets installed into your Stack Elements Library. You’ll need to go to the Stacks Library and drag and drop it from there onto your page. If you’ve installed it and restarted RW the error message on your Stacks page should go away.


(Phyl) #7

I have tried to drag and drop onto page. Restarted RW. Restarted my mac. Did not work. this is frustrating. I have no idea why this happened.

Do I have to drag and drop to a special place??


(scott williams) #8

Try to grab your two column (inside the missing one) and drag it above the missing one.
Delete the missing one
Then see if you can add the new one.


(Robert Ziebol 🖖🏼) #9

There have been many versions of the EC stack, you must not have the one that you redownloaded.


(Isaiah Carew) #10

The screenshot above shows that there is a stack called ExtraContent installed (you can see the icon in the library). And it also that there is a stack called “extracontent” that is missing (you can see the warning and red-stripes).

So something is clearly out-of-whack. There are a few possibilities here:

  1. Stacks is just confused.
    You can try Quitting all the way out of RapidWeaver and then re-opening your file. That should start things in a stable place. If nothing changes, then try…

  2. The installation of the stack didn’t work correctly.
    In this case you can try to de-install and re-install the stack.

  • Click the Gear menu under the Stacks Library and choose Show Stacks Library in Finder.
  • Look for a Extra Content stack. Remove it. If there are several, remove the all.
  • Download a fresh copy of the stack from the developer. Unzip and drag into the library by hand.
  • Quit and re-launch RapidWeaver.

If you still see the same issues then…

  1. The file you’re opening was not created with the stack that you have installed. In other words: the file was created with a stack named “extra content” and the stack you installed was also named “Extra Content” – but even though they share the same name they are different at their core.
    In this case you may want to contact the developer of the stack to help you work through the problem. If you cannot figure out who the developer is, you can contact http://yourhead.com/support and we can help you locate the developer.

Isaiah


(djrshopping@mac.com) #11

I had exactly the same problem with the ExtraContent stack. Fixed by reinstalling.

Latest version of stacks, rapid weaver etc.

Since then however I have had further problems. I purchased the Potion_Pack for Foundry, double clicked on the install icon and received a message that installation was successful. The stack was not however available when I restarted RW, nor was it present in the dropbox folder chosen for add ons in RW preferences. There was however a folder for foundry_potion_pack in the application support folder of my library

~/Library/Containers/com.realmacsoftware.rapidweaver/Data/Library/Application Support

I solved the problem by dragging the stack directly into the appropriate dropbox folder but is there an underlying problem with the default location for installation in the latest versions of the software?

Many thanks for any advice

Dave


(Robert Ziebol 🖖🏼) #12

I have seen issues of installing stacks when people have more than one version of RapidWeaver installed, specifically RW 5, 6 & 7 all on the same system. I never use installers any longer and tell people not to either. Joe’s stacks are inside something called .rwaddon (not sure what the Potion Pack is like). I tell people to drag and drop that onto the RapidWeaver icon in the dock and it seems to install. I think installers might be getting confused as to where to install if multiple copies of RW are on the system. You can always control or right click on an installer and show package contents. The actual stacks will be in there and you can then drag and drop those stacks onto the RW icon to install. Also, remember that developers are tricky people (not really :wink:) and even though you know there is a group of stacks, they might only show one stack in the contents, and installing that one stack will install all of them.

Hope this makes sense and helps anyone out.


(djrshopping@mac.com) #13

Many thanks.

I did wonder if it might have something to do with having RW6 still installed but when I checked that programme the stacks were not installed there either. The Potion Pack is a disk image with the stack icon present and like many others a simple double click on that should install.

I have installed a variety of other stacks in exactly that way recently but only just experienced the problem discussed. Could this be a problem with recent updates of RW, stacks or even MacOS?


(Robert Ziebol 🖖🏼) #14

Another thing I have recently started doing was to put shortcuts to my Stacks library folders on the side of my Finder windows, that way you can drag and drop the stacks right into the folder there and then you know they are installed. Just another way to do it.

No clue.


(Isaiah Carew) #15

One more “pro tip”:

If you’re having issues with addons, especially with installation, I’d recommend:

  1. Avoid Dropbox for your addons.
    Dropbox often moves things around a bit as it syncs items with your online Dropbox – this can sometimes trigger RW or Stacks to attempt to re-install the stack. Even just the addition of the green-checkmark makes a tiny change to the file meta-data – which can also trigger this sort of behavior.

Under normal circumstances this should be fine. But if you’re experiencing problems, it’s definitely on the top of my list.

  1. Avoid custom addons locations.
    I have received many support requests recently of Stacks (the plugin) and/or 3rd party stacks going missing – sometimes while RapidWeaver is running. All of them have one thing in common: a custom addons folder location. Somehow, (I suspect after a backup-restore or system update) the folder becomes “unhooked” and confusing RapidWeaver. This then causes items to be installed in the wrong place, or even loads the wrong addons.

Once things are working smoothly again, you can try a custom location or DropBox – and see if problems return.

Isaiah


(Ken) #16

Just a simple question - does the ‘Theme’ you are using support extracontent(s) ???