Who uses Cloudflare?


(Lisa Sandler) #1

My site has not been rendering properly and I was just told by a developer that Cloudflare doesn’t bring any real benefits to a website, except for maybe SSL. What are you thoughts? Should I get rid of it? @barchard since you’re my host at Chilling and all things cpanel-wise
Thank you


(Joe Workman) #2

I am a huge fan of Cloudflare and think that this other developer is wrong.


(Lisa Sandler) #3

Joe, thank you. Can you please elaborate on what you think the virtues are for you?


(Joe Workman) #4

Speed, Security, Speed, Awesome DNS management, Speed, Security. I have talked in length about this many times. There was a great session on Cloudflare at WSC2016. There must be a ton of posts on Weaver’s Space as well. I talked about it on the podcast as well…

Did I mention speed and security?


HTTPS / Cloudflare resource
(Doug Bennett) #5

What is your site doing? Doubt it’s CloudFlare causing the problem, but sign on to CloudFlare and change the status to development mode. That will “turn off” CloudFlare’s cache for 3 hours.

Benefits of CloudFlare:

  • PERFORMANCE - pages are cached and served from CloudFlares CDN. This will usually serve pages much faster.
  • RELIABILITY - By running through CloudFlares CDN, pages are served on redundant servers. Bottlenecks from shared hosting plans won’t prevent page loads.
  • SECURITY - IN ADDITION TO OFFERING SSL, Protect Against DDoS Attack.

(Lisa Sandler) #6

Something called Rocket Loader?


(Lisa Sandler) #7

thank you, Joe. I listen to all developers and advice here, so it’s appreciated.


(mark hunter) #8

Rocket Loader is a Beta Feature Lisa, I had problems rendering some pages in IE when I had it switched on - turn it off and see if that cures it.

Regards

Mark


(Doug Bennett) #9

Rocket laoder should be off by default.
Log on to CloudFlare:

Select Speed:

Scroll down and find rocket loader and turn it off:


(Lisa Sandler) #10

Thank you, it was set to on.


(Doug Bennett) #11

Is it working now? If not go to Caching, and select purge everything.


(Lisa Sandler) #12

Yes, seems to be. I was clearing the cache in CF before but it didn’t seem to work. Now it seems to work on desktop, but how do you clear a browser’s cache on a phone?


(scott williams) #13

On iPhone it’s under settings/safari
Not sure on other platforms


(Lisa Sandler) #14

Yeah, thanks Scott. Safari is the one holding on. Firefox and Chrome seem to be fine.


(Joe Workman) #15

I have only ever had two issues that can be turned off in CF. Rocker Loader (which is off by default) and Minify JS. Rocket Loader got a huge overhaul about a month ago and it seems to be better. However, I did has some minor issues that they are looking into when I put it on WS.

I should add that I use CF on every website that I run.


(Lisa Sandler) #16

Do you recommend turning off Minify JS?


(Joe Workman) #17

It works most of the time but it can beak some JS code in some stacks. I recently turned it back on as a test and have not found any issues. That does not mean that there aren’t any.


(Doug Bennett) #18

You probably already have minified JS. RapidWeaver has that option in advanced settings, and I think it defaults to on. In addition, a lot of the stacks, plugins and themes already “minify” the JavaScript. Minify removes spaces, comments and line breaks making the Javascript file smaller to load faster. Doing it multiple times doesn’t help.
2018-06-28_10-16-01


(Lisa Sandler) #19

Thanks. Yes, I had that set in RW so turned off Minify in CF.


(Noah Palmer) #20

I’ve got a free account to avoid having Google’s Chrome browser mark my sites as insecure.

I think that Cloudflare says it offers DDoS protection, but unless a site is political, that’s probably not a concern.

The only problem I’ve encountered is that if your site has subdomains, Rapidweaver can’t publish to the subdomains unless you first “pause” the Cloudflare service. Then you publish. Then you un-pause. It took me about three days to get a solid answer for that question, so I wanted to save you the trouble.