Wit's End About Publishing (Resolved)

I’ve been able to publish my site without problem using my regular ol’ publishing settings, settings I’ve not touched for a very long time. One day last week, though, after moving a subpage from below a page to be below another page, suddenly I cannot publish under any circumstances. The only change I made from one minute to the next – literally, I had just published a minute before – was moving the page.

Since then, I have tried absolutely everything I can think of. I put the page back. I changed themes. I have cleared all unused resources. I’ve tried different FTP settings and different server settings. I have deleted the original offending subpage. I reverted to all original settings. Nothing I do helps.

I now have 270 pages, down several since the ordeal began, and when I publish it gets anywhere form 29 to 48 uploaded pages in, then suddenly times out saying I can’t upload to my FTP server. Two of the blue “I” buttons says a timeout was reached and a third second says an operation was aborted by an application callback.

Does anyone have any idea what happened when I moved that page and how I can fix it. I’ve already spent lots of hours trying every variable I can think to change, scanning these help forums and trying other people’s fixes, but I just keep striking out. I figure there are variables I don’t know to check, so your ideas are very welcome/needed. Thanks.

Try publishing to a ‘local folder’ on your desktop - if that works use an FTP program to upload those files in the folder to your server - FileZilla is free if you don’t have one.

Once you moved the page it created a change to your navigation. That triggered the need for every page(270) to need to be republished.

I would first do what Dave (@DaveFox) said and try to publish to a local folder first. That would tell you if there is a problem generating the pages.

If the local folder is published okay, then you can use a standalone FTP app to get the pages back onto the server.

Don’t forget that RW won’t delete anything on the server, so you’ll need to use something like the FTP app to do housekeeping.

Once you have that going if you want help with getting RW publishing working again you can post back here for help. To get help with publishing you’re going to provide a bit more information.

  • Name of hosting company
  • screenshots of your publishing settings and error messages.

I’d also recommend following the steps in our help guide wit FTP issues: How to fix Publishing Issues!

Thanks, DaveFox. I can publish locally and upload via FTP, so I haven’t lost the ability to update. I am hoping to avoid having to do it daily if there’s any way I can get regular publishing to work. I see other have responded, too, so I’ll update more there. Thanks, again!

1 Like

Thanks, teefer. I can’t believe how responsive everyone has been.

I have been able to publish locally and update via FTP. I have also pruned files off the server to make it as clean as possible.

The name of my hosting company is Jumpline.

Here are some screenshots of the settings that always worked previously:

Screen Shot 2021-04-04 at 12.02.24 PM

Again, thank you.

Ah, Dan, thank you. I will check it out to see what I may have missed right now.

I checked their knowledge base and they don’t list FTPS as a supported protocol. Now perhaps they haven’t updated their KB yet but I think that’s part of the issue.

Since you are able to publish via a standalone FTP app perhaps you can share a screenshot of the settings you used.

Just going by their Jumpline is now HostPapa - Web hosting, email & domains article for Filezilla, it says to only use one connection (you have it set to 3) and to use passive mode.

I see what you are saying about FTPS, but when I set to simple FTP in RapidWeaver and hit Test it gives me an immediate Timeout response. When I set it to FTPS and hit Test it connects successfully; when I try to publish on FTPS it allows to upload a number of files, never the same number of files, before timing out.

I have reduced down to one connection (and tried all of the others) but it, too, eventually times out.

Screen Shot 2021-04-04 at 1.07.41 PM

Again, thank you for the incredible responsiveness.

Oh, and: I have also:

  • Tried to vary my site paths multiple different ways
  • Browsed to different site path locations, just to see if it would upload
  • Varied my server configurations every way possible
  • Limited concurrent connections
  • Uploaded files via Transmit

That first photo in my last message is my Transmit settings page.

Not sure how much help I can be. The host has no info using FTPS, and I never use it. I only use SFTP.

FTPS uses multiple ports( separate command and data channels)and good firewalls can cause issues. It also uses two different encryption FTPS Implicit SSL and FTPS Explicit SSL. This can make it difficult to debug.

When you hit test using FTP and it falls, this usually indicates that the basic credentials(server name, username and password) have an error.

Thanks, Doug. I have a ticket in with Jumpline to ask about the credentials. It’s baffling, though, since everything worked fine with those credentials until the moment I moved the supage and had to republish all files.

I’ll keep punching the bricks until something comes loose. If I find the solution I’ll post it here.

I can’t tell you what is going on. I did noticve that the server name you use is changing in the screenshots above.

The first Screenshot shows a Server of cpanel06.myhostcenter.com, that’s also the one you show in the Transmit panel that worked for you.

The later screenshots (the ones that fail the test) show a server name of ftp.santa-lechuga.com. Not sure why that would have changed.

When debugging issues, it’s best practice to limit what you change per test. It could be the server name, part of the base credentials that get tested with the test button is wrong?

Unfortunately your hosting company doesn’t seem to have anything in there knowledge base for publishing using FTPS. They do cover FTP and SFTP. So I don’t know where you got the inital settings from.

You can try to publish a single page at a time. Simply right-click the page and select Publish Page.


I have held every variable constant while changing every other variable during hundreds of tests I’ve tried since last week. So those were different screenshots from different troubleshooting efforts.

Having said that, Jumpline’s documentation and tech support said I could alternate trying the cpanel address or the ftp address to my website for the server. The have both worked in the past via RapidWeaver and they both continue to work via Transmit.

FTPS continues to be the only way I can connect via RapidWeaver, so I assume my credentials are valid. Or do my credentials change depending on use of FTP vs. FTPS?

I will try the Publish Page approach to see where that gets me.

As before, thank you.

Alright. I was able to Publish Page on all but form pages, forms created with FormLoom 4. I deleted all three of those and instantly everything else is publishing.

I never thought to delete those because I didn’t move those pages, but I suppose since everything had to be republished they were affected. I just don’t get why those all worked previously and now they aren’t working.

Time to go forum surfing again.

Thanks, all, for your help.

I’ve had this problem for months. Started moving to Wordpress. Have never received any worthwhile support from Rapidweaver on the issue. The whole point is that one is able to click “publish” and all is done. Not to export to local and then fiddle with an FTP. Extremely frustrating. I rebuilt my website with no positive results. I’m just stuck now with Rapidweaver (since 2002).

Good luck with your switch to WP. It’s an each to his (her) own situation, I’ve used RW on 15 sites over 6-7 years, made a reasonable second income from them and never once had to publish ‘local’ and then use FTP unless I chose to, I guess you’ve just been unlucky.

Perhaps we can tag @dan here and he can look at your publishing problems for you @earthprobiotic

@earthprobiotic what seems to be the problem, can you give us some more information here?

It’s often just incorrect credentials that causes a publishing issue…

Step 1. Download Transmit.app/Cyberduck.app or similar and enter your publishing credentials and see if it connects and works as expected. If not then it must be that your credentials are incorrect and not a RapidWeaver issue. If they do work, move on to step 2…

Step 2. Add a new publishing destination in RapidWeaver and enter those exact same details. See if RapidWeaver will connect and publish. If not, drop support@realmacsoftware.com an email and we’ll try and dive deeper and help resolve the issue.

Also, check out our new help guide (and video) on publishing issues:

Hope that helps.


Hi Dan,

I’ve done all that.

Transmit works perfectly.

Credentials on “publishing test” are all OK.

Browsing for destination is all good.

But have exactly the same persistent issue as per the original poster.

So now it’s a whole new workaround — and I don’t want to risk publishing via RW now as I don’t want to corrupt my current site.

I’ve spent so much time trying to resolve this — at least lockdown gave me some time. But it’s a +10 months problem.