Access to one of my testsites denied


(tomas nittner) #1

hallo friends of the arcane wisdom of rapidweaver,
more than a year ago i published some content on one of may test sites for the client to see. specifically he wanted to try out a “page lock” possibility by which he would have to enter a username and a password to access the site. all well and good, the customer was happy i transfered the whole shabangh to his proper url and deleted all the files via “forklift” fro the test site, namely: http://test.tn089.de/
and that’s where my problem begins… mind you, there is no content whatsoever on the server for this adress, everything got deleted and yet it prompts me to enter username and password.
anybody have any bright idea what to do? .htaccess file - and if - how do i go about to make it visible on my server? i am at a loss and any help would be greatly appreciated,
tomas


(scott williams) #2

If you can’t edit the.htaccess file with your Cpannel (you probably can) set your ftp program to show hidden files and you can edit the file with that.


(tomas nittner) #3

thanks much @swilliam, that did the trick! now of course, i don’t really quite know WHAT to delete… here is the file in all it’s glory:
<Files ~ “^_pa”>
Order allow,deny
Deny from all
Satisfy All

AuthType Basic
AuthName "My Content"
AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords
require valid-user

also, of course it shows up greyed out, will it save alright if i alter it?
thanks again,
tomas


(Mark Sealey) #4

Tomas,

Put a hash/‘pound’ # in front of the line which is denying access to everyone who tries to access the site:

# Deny from all

that will comment out the line and let visitors in. Good luck!


(tomas nittner) #5

thank you @MarkSealey for your efforts. unfortunately even adding the hashtag - as per your direction - didn’t do the trick:
<Files ~ “^_pa”>
Order allow,deny

Deny from all

Satisfy All

AuthType Basic
AuthName "My Content"
AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords
require valid-user

what happens if i delete the htaccess file altogether? will it just recreate a new one without any “adornements”.
thanks again for your help,
tomas


(Mark Sealey) #6

Tomas,

I think I can see why. These lines:

AuthType Basic
AuthName "My Content"
AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords
require valid-user

are setting up a password challenge. The expected logins and password are contained in the third of those four lines quoted.

This makes me think to ask you, How much did you change your .htaccess file; and why?

Rather than waste your time guessing about the configuration you want, would this page be useful?

It explains how the .htaccess file works. Maybe some of the settings are left over from your page lock? It certainly looks pretty successful, doesn’t it!

Alternatively, is this:

Order allow,deny
Deny from all
Satisfy All

AuthType Basic
AuthName "My Content"
AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords
require valid-user

everything in the .htaccess file in question?

If so, I’d suggest commenting almost everything out, thus:

Order allow,deny
# Deny from all
# Satisfy All
#
# AuthType Basic
# AuthName "My Content"
# AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords
# require valid-user

at which point you should be able to access the file from the browser (again). If those are the only lines in the .htaccess file, and if password protection really is not required, you might be able to leave it at that.

(Or - if there are other lines - you could uncommon them one at a time until it stops working. But I suspect you may be OK without any of them, if there is no need to protect the page(s)).


(scott williams) #7

My guess is Mark is correct, you probably don’t need any of that.

That being said, I believe @joeworkman has a .htaccess tutorial or video on his site. Maybe hop on over there and give a search.

Astually, here it is: https://joeworkman.net/tutorials/


(tomas nittner) #8

thank you ever so much @MarkSealey and @swilliam! looks like i screwed up big time this time :frowning: i am getting this message from the server:

after alter the htaccess file to this:

<Files ~ “^_pa”>
Order allow,deny

Deny from all

Satisfy All

AuthType Basic

AuthName “My Content”

AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords

require valid-user

i also tried all other combinations, no luck. what happens if i delete that ferschlugener file all together? will the server just create a new one?
somewhat puzzled…
tomas


(Mark Sealey) #9

Tomas,

Placing a ‘pound’ or ‘hash’ sign (usually SHIFT-3 on a Mac), #, at the start of each line means that the server ignores that line.

So you should edit your .htaccess file to look like this:

Order allow,deny
# Deny from all
# Satisfy All
#
# AuthType Basic
# AuthName "My Content"
# AuthUserFile /webspace/11/77486/test.tn089.de/index_files/_passwords
# require valid-user

I used the sixth icon along from the left, the ‘perforated text’ icon: the left chevron-forward slash-right chevron to paste these settings here. Please do the same so that we can see exactly what your lines look like.

There is no harm in leaving

Order allow, deny

without the leading ‘#’

If there are no other lines in your .htaccess file (are there?), then none of its directives (lines) will have any effect because the leading hash disables them.

Suggest you take a look at the URLs mentioned in this thread and - if necessary - construct a ‘harmless’ .htaccess file from scratch.

You could try deleting the .htaccess file which you have already. But I suggest renaming it to ‘htaccess’ (without the dot at the start) just in case. Good luck!


(tomas nittner) #10

hallo @MarkSealey, well, i tried everything you said to no avail. then i figured, what the hell, this whole .htaccess file serves the only purpose to block the site - which i don’t need anymore on my testsite. before doing it i checked on all my other sites and lo and behold no .htaccess file. so i deleted it and it WORKED! my site is ready for further testing. i tried it out with some files - worked beautifully.
thanks much for your help and kind regards,
tomas
p.s.: incidently the hash mark on my keyboard (german) sits right left of the “return key” in the row of the “A”.


(Mark Sealey) #11

Good, Tomas!

Though in fact - we strongly encourage you to review the pages explaining .htaccess - an .htaccess file can do much more than manage passwords. You would be well advised to follow some of the information there to make sure that you understand how and when to use an .htaccess file without restricting access… redirects and blocking spammers addresses for example

Viel Glück :slight_smile:


(tomas nittner) #12

thnx @MarkSealey, did exactly that as soon as i got the adresses from you and put it in my bookmarks for future reference!
greetings, tomas