AddOn problems upgrading from RW7 to RW8

hi. I’m attempting to “move” a site I work on from RW7 to RW8. And it’s driving me nuts, because I can’t figure out how to get my various addons to be seen by RW8.
This is on a Mac Mini, with a newly installed version of Big Sur.
I saved the site in RW7, and made a safety copy of the file.
Right clicked that file & opened it in RW8.
The site file opens, but none of the plugins are installed. (“This stack is not currently installed…”)
“Copy addons from RapidWeaver 7…” is greyed out.
I then tried double clicking the various stack files in Finder to reinstall them. But although that process ran (via the RW install window), the site still opens without the addons, and they don’t show up in the Stacks Library.
I also tried manually installing them by drag and drop - I’m not sure if I’m supposed to do that (or even if I put them in the correct location), but it didn’t work.
I’m confused and at a dead end.
Any help or pointers gratefully received!

If nothing else works (and it sounds like that’s the case) then moving them manually is the way to go.

  1. Open RW7
  2. Hold down the option key (this is the magic) and choose Reveal Addons Folder from the View menu. Cmd-Opt-7 works too.
  3. You can quit RW7 now.

This will show your RW7 addons in the finder. This is all the stuff you want to copy over. Now let’s do the same to get the RW8 window open.

  1. Launch RW8
  2. Choose Reveal Addons Folder from the View menu (no option key required anymore) Cmd-7 is the command key now. Cmd-Option-7 no longer works.
  3. You can quit RW8 now.

So now you should have both open. From here it’s up to you what items you copy over. I’d recommend just installing as much from scratch by downloading it directly from the developer. There may be new versions for RW8 that you don’t yet have. By downloading them directly you’ll be sure to get the latest and greatest.

I’d also recommend taking this time to prune things that you aren’t using. I find most users, even if they own 10 plugins, only use a few, or a few at a time.

And lastly, do a quick check to make sure nothing is irregular:

  • Make sure there is only one copy installed
  • Make sure they have the correct name, not something like Stacks 2.rapidweaverplugin it should just be Stacks.rapidweaverplugin
  • Make sure there isn’t a second copy of an installed plugin inside the Plugins Disabled folder. There should only be one copy anywhere.

This last item is very common. I suspect some automatic process, like updating, or installing, sometimes allows this situation to happen. Once there is a copy in both the main addons directory AND in the Plugins Disabled folder, then RapidWeaver will report that the plugin is disabled, but you will be unable to enable using the RapidWeaver Addons window.

It would be very nice if @tpbradley could have a look at that situation. :slight_smile:

Once you have things moved over and cleaned up you can start RapidWeaver and hopefully all will be well. If you still can’t see your plugins after that, then the situation is probably more dire and out of my paygrade – you’ll need to contact Realmac support for help.


hi Isiah, and thanks for that detailed breakdown. I’ve finished for today, but will have a go at this tomorrow morning. I think I might delete RW8 & its folders first, as at the moment they’re all full of things I already tried copying across and there are duplicates all over the place. (For some reason I have an additional Stacks folder inside the Plugins folder. That can’t be right!)

That appears to have sorted things out (only a quick check on the site so far).

The post above is incorrect (and it would be good if you removed it – to avoid confusing people)

Here’s the correct structure:

I’ll start with the RapidWeaver addons folder

  • RapidWeaver
    • Stacks.rapidweaverplugin
      when you install plugins, RapidWeaver moves them here
    • Stacks
      • Foundation.stack
        when you install stacks, RapidWeaver moves them here
      • Externals
        • External001.stack
          when you create a External in Stacks, it will be automatically placed here
      • Templates
        • FoundationTemplates.stacks
          when you create a Template in Stacks, it will be automatically placed here
    • Snippets
    • Themes

calling all pros: please let me know if I’ve made a typo there – that’s a lot of detail without any syntax checker. :stuck_out_tongue_closed_eyes:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.