All stacks missing

I have somehow got into a muddle.

I upgraded stacks to latest version 4

I also updated Foundry

Now when I open any project it shows all stacks as missing.
I tried reinstaling Foundy and Stacks but still no luck.
I think somehow they are in the wrong folder.

In the inspector far right under addons I have checked add ons location Managed by Rapidweaver but still no luck. Somehow it seems that all my stacks have moved to the wrong place .


Installing the Stacks add-on itself shouldn’t move your stacks themselves.

Where was the last place in which you kept your stacks - with or without Management by RapidWeaver?

I think in Aplication Support? Im not actually sure. Things have been humming along nicely for years !

I had not paid attention. I ma7y have sone something … but not sure what !

If it was in your ~/Library/Application Support folder it ought still to be there. Maybe in a subdirectory.

I’d have said it was (almost) impossible for all your stacks to have moved themselves (or been moved by an installation of something else - especially Stacks itself) to the Trash.

Suggest try searching in/with Spotlight for another RW add-on or Theme which you know exists, and see if your stacks are in the same directory or sub-directory. Good luck!

Thanks so much Mark for helping me! Its turing into a nightmare as Im now on day 2 of no work done.

My stacks seem to be everywhere. I have litterly hundreds. But when I open a new fresh RW project I only have very few. ( About 20) When I look in aplication suppport / Rapidweaver I have loads. BUT not all. For example I have wall stack in there but not wallpaper.
When I locate wallpaper stack and look for path it says searching this mac. DSo I dont know whre to find it.
I am hesitant to move anything until I know im doing the right thing and things are in the right place.
I have about 30 RW stacks projects that need updating several times within the year so Im scared im going to screw them up!

I think I can track down all stacks and plugins and place them all together in the correct folder… / folders but im wondering how best to do this and best place for them. So that I don’t do this again


So sorry to hear of the trouble you’re having; it must be driving you crazy :frowning:

I’d hate to offer you too much advice without knowing the disposition of RW-related files on your machine myself.

First, two questions:

  1. which version of RapidWeaver itself are you using?
  2. where were your stacks in the backup of your machine immediately prior to upgrading to Stacks 4?

Then, I’d suggest you create a folder (e.g. on your desktop) and copy (not move) all these stacks which ‘seem to be everywhere’ into it so that you will have them as a backup in case anything else goes wrong.

I confess to being surprised (and a little disturbed) that files seem to have moved themselves into various places on your machine without intervention from you or any other software. Do you have good anti virus protection?

Next, I’d decide where you do want your stacks to be located. I have RW 8 and - since it allows it - I keep all my add-ons in a subdirectory called RapidWeaver Add-ons in ~/Library/Application Support.

I think I’m right in saying (and Stacks developer @isaiah will correct me if I’m wrong) that it is safe to override for the moment the way in which RW handles locations of the stacks themselves. Do it at the filesystem (Finder) level. RW is designed to look for add-ons in one place. When they’re there, it will find them.

Get all your stacks aggregated in one place - e.g. a subdirectory in your user library (~), although it could just as well be in the Documents folder, tell RW where they are, and start from there.

The fact that RW (if I understand correctly) seems to be finding some of your stacks suggests that it does ‘know’ where it thinks they should be (hold down option and select ‘Reveal Addons Folder’) and that some of them are there.

You could - after making the backup I suggest - simply make sure that your now scattered stacks are all safely located in the folder which RW identifies from the option above.

Do you keep the ‘originals’ of your stacks’ files? Ideally, to rerun the install process of each and locate them all in the folder just mentioned is the best solution, I’d have said.

But I’d also reluctantly suggest that you explore the possibility of some sort of unplanned intervention (corruption or malware) if you really are getting files moved ‘by themselves’. Please let us know how you get on and good luck!

Different versions of RapidWeaver store add-ons in different places. The problem you’re seeing is probably caused by the upgrades. There is likely a new addons folder somewhere sitting lonely without any stacks – we just need to get the old stacks in there.

The solution is simple:

  • First open the old addons folder.
    You seem to have a good idea where that is, so I won’t bother explaining that bit.

  • Now let’s open the new addons folder. I will explain this one.

    1. Open RapidWeaver
    2. Create a new document.
    3. Add a new stacks page.
    4. Click the gear menu at the bottom of the Stacks Library.
    5. Chose “Show Stacks Library in Finder”
  • Now that you have the new one open and the old one open – just drag them from the old spot to the new one.

Other things that can create chaos during an upgrade:

  • make sure you just have one version of RapidWeaver and one version of Stacks on your machine.
    if you have more than one version, then it’s possible that sometimes you’re launching one version and sometimes you’re launching the other (e.g. maybe the new version launches from the dock, but the old one if you double click on a project file).

  • if you’ve also recently updated to Catalina, then make sure that all your plugins are updated to the very latest versions – Catalina has strict requirements for plugins. they all must be “Notarized” by Apple. all of our latest versions are properly notarized, but earlier versions may not be.

  • if you’ve recently updated, restored from a backup, or moved your files to a new computer – makes sure that your file permissions are correct.

If none of this seems to be helping, then it’s time to collect a little bit more info about the details of your system – versions, machine, etc. What version of RapidWeaver you’re using, and if you’ve updated recently. And any other sorts of exceptional things that may be going on.


Thank you. Yes I think all the upgrades have seriously got me in a muddle. In the last couple of months I have upgraded Stacks and Foundry and updated to Catalina. Though all was well for a while and I dont remember doing anything that would have chaned things over. THOUGH since trying to fix this I feel I have made things worse and got things even more muddled.
ie I have been using Stacks 4, But now being told to update V3.
I think the big thing I did wrong when things wernt working was to change Addons Location to be managed by Rapidweaver. Thats when things really hit the fan.
Actually I have the most insane ammount of plugins and stacks and themes. most of which I no longer use. So if I can get back to the start without them all. (But keep them in a back up folder incase I find I need them when updating an old site ) That would be ideal. I really need to thin it all out.

At the moment when I follow your steps above I get to step 4. When I click that gear at the bottom of the stacks libaray nothing happens. ie I dont see stacks library in finder. However if I select a stack and click the right gear icon and show in finder I can find where RW is pulling these stacks from. If I hit Path from top menu I see
Mac Book Pro
Macintosh HD
Rapidweaver 8
Stacks 3 (even tho am using stacks 4)

All my themes are not in the correct place either. I just have the ones that came with RW.

This is with Addons Location to be managed by Rapidweaver.
But if I try creating a file of stacks on my desk top and select that it is the location … it does not work, I do not see those stacks avail to select from.

SORRY I’m such a bore. Im so grateful to you for helping me. As you can see I cannot do it on my own! Have litterally been here for 2 days trying but think I have made it much worse!

It sounds like there are still some things tangled – starting with the fact you definitely have Stacks 3 installed. I made a quick little video that I thought might help get things untangled a bit more quickly. It walks through installing Stacks 4 and moving over your old stacks. Give it a watch and follow along and hopefully you’ll be up and running in no time. :smiley:

Thank you 1000000 times for this.

Im still stuck at the show stacks library in folder step because for you a finder window pops up… for me zilch. Should I reinstall Rapidweaver 8?

how about the RapidWeaver preference for the addons folder?
is it still set to a custom location? if so – i suspect that’s your issue – perhaps it’s set to a location that no longer exists – or you no longer have access to.

i’d recommend reseting that to “Managed by RapidWeaver”

and if it is set to Managed by RapidWeaver already – then I’d recommend doing exactly the opposite and setting it to a custom location. Create a brand new folder right on your desktop – and set the location to that folder.

Once you’ve flipped that preference, restart RapidWeaver and give things a try again.

I created a new folder on desktop and added one stack to it.
I changed from Managed BY RW to the folder on desktop.
When I open stacks library I see the 10 stacks and strill the gear icon does not open the desktop folder with the one stack. Even though it is set to that new folder

Soooo Even though Adons location is set to folder on desktop.
The stacks on offer tro me (tho cant find in fincer by clicking gear are coming from this path
top menu I see
Mac Book Pro
Macintosh HD
Rapidweaver 8
Stacks 3 (even tho am using stacks 4)

It says stacks 3 up there but am on 4 !~ (reinstalled again this am)

I have backed up my hard drive

Should I delete RW and reinstall?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.