Annoying auto-complete in css pane


(Markus Frieauff ) #1

I don’t know if this is set by RW or by something else on my mac, but when I enter CSS code in the css pane, I always get autocomplete proposals that really turn me off: I type “a” as identifier for a link, but immediately it becomes “above” - which is not what I want and before I can delete it RW has started to refresh the page. Damn.
Where can I turn that off?


(webcore) #2

I don’t think its intended to be used in Preview mode (if you value your sanity!).
It would be nice if it had an option to turn off auto-refresh and a refresh button or shortcut we can use to manually refresh the preview for when we are simply writing css. Or alternatively a better algorithm to only refresh the Preview if the user stop writing CSS in the panel for X (user configurable) seconds.
It’s (fixed) width also doesn’t help. Maybe i’m missing a setting or something too…


(Rob Beattie) #3

Yep. Autocomplete is a pain in the patoot.


(Peter Danckwerts) #4

Yes, autocomplete is a complete nonsense. It’s like the irritating feature of some word processing software which thinks it understands English grammar better than you do. At least you can turn that off but, unfortunately, you can’t currently turn off RW’s autocomplete. Please get rid of it, RM!


(Oscar Schmid) #5

The suggestions are quite helpful, sometimes.
You can just keep typing until the correct word is displayed, and then click.
But that the proposals are adopted immediately is very tedious.

Enter code only in the edit mode.
You can not turn off “Refresh” and “Auto-Complete” in RW, unfortunately.



(Peter Danckwerts) #6

Unfortunately, it doesn’t always come at al;l. In any case, to be of any use, it should speed things up rather slow them down!