Armadillo Database Access Problems - GoDaddy


(John Adams) #1

Hi,

While in search of a user friendly blogging solution for my daughter use with a CMS type approach, I thought that based on what I read on Armadillo’s site that this would do the trick. Its much less complex than other CMS solutions and can bee accessed via iPad

I am hosted through GoDaddy and have two basic Linux hosting accounts which as well as MySQL have a choice of PHP 5 or 5.6.

I’ve had Easy CMS running

According to GoDaddy I have the correct address for my database and login credentials.

One thing is that with my “cheap hosting” GoDaddy do not allow remote access of a database on PHP5.6 but it is allowed on PHP 5. But since its a PHP script on the server running then I assume that I do not need remote access.

I have Armadillo main stack installed on its own page and have completed all the required details. Its all straightforward

I have the actual blog page setup elsewhere on my site as per the directions

Armadillo does not appear to be connecting to the db and I get no message - except when I move on to completing the set up on the live site I just the link to a text only version of my home page or “no input file specified” message and in fact if I remove all data from the db dialog box and leave the db location as localhost and republish - I still get the same error messages.

Has anyone here had this problem?? And is there a solution. I’d rather like to start using the stack…

I have emailed Johnathan at Nimblehost but have had no response as yet. @nimblehost

I am running 2.8.1.Armadillo Stack. RW7.5.2, Stacks 3.5.5 and Sierra 10.13 - just in case it matters.

Any thoughts very much appreciated. Its got to be simple right??

John A


(Gary White) #2

Has been a while since I set up Armadillo, but I do recall that the php.ini file needed to be named php5.ini to work with GoDaddy - could that be it?


(Peter Danckwerts) #3

No, you don’t need remote access to the database and you do need PHP 5.52 or later. If you’re using PHP 5.6, I’m afraid I don’t know what is going wrong.


(John Adams) #4

Thanks Peter. Yes I am on PHP 5.6… Its frustrating LOL. But hey thats whats interesting right! I know I will get there and I am sure Johnathan will be able to point me towards the fix


(John Adams) #5

@GaryW17 Thank you.

I am on “shared” hosting with GoDaddy. So the php.ini file has to be in my root to “over ride” their php.ini file and yes it has another name which is in my case php56.ini because I am running with php 5.6

Go Daddy confirmed that my database is online and working with the credentials.

So I am assuming (and you know what assume does…) that my php56.ini has to contain some information about the connection to the database. But I assume its just a configuration file. How to get the .ini file?? Do I need it?? Maybe the developer will help me here.

Any suggestions gratefully received…

And thanks for that clue


(Gary White) #6

I am pretty sure that the ini file in your root folder should be named php5.ini - in my case I know that mine is running PHP 5.5, and I have a php5.ini file in the root folder. Just create the file with a text editor and place it in the root folder. All that is in the file is one line: cgi.fix_pathinfo = 1

Hope that helps.
Gary


(John Adams) #7

@GaryW17 Again thank you for your help.

Yes, I have tried both the php5.ini and php56.ini files in my root with that line.

Looking at the files generated by Armadillo I think the key is the index.php file in the /rw_common/plugins/stacks/armadillo directory which looks like it should be creating the link to the database.

I think the php.ini files are just configurations of the php program on the server.

Regards

John A


(Jonathan Head) #8

@jaa6921 Based on what I see on on your website, the cgi.fix_pathinfo setting does indeed need to be enabled. However, I do not know if GoDaddy allows that setting to be changed via an .ini file under their “classic” hosting plans.

Based on past experience, making this type of change is possible with some of their shared hosting plans (particularly the current ones with cPanel Linux), but not others.

Hope this helps.


(John Adams) #9

@nimblehost Thank you for taking the time to review my “setup” and as we suspected its a feature of the Economy Hosting at Godaddy that limits the functionality and they are unwilling to adjust anything that could impact others.

So the answer was to upgrade to cPanel Linux hosting and it worked first time.

Hope this may help others that try to implement Armadillo on older hosting configurations

Thanks again

John


(system) #10

This topic was automatically closed 6 days after the last reply. New replies are no longer allowed.