Rapidweaver 7 - Can't Publish


(mik777) #1

After upgrading to Rapidweaver 7 I am again unable to publish my site using the publish button. It took months for this to work for me with Rapidweaver 6, so on the promise that Rapidweaver 7 bugs were ironed out prior to it being launched I had hoped I wouldn’t have the same issues.

Opened my RW6 site with Rapidweaver 7 and explored all the changes. I then updated a few photos and some text. I didn’t change anything in the publish settings. When I try to publish I get the dreaded warning - Unable to Publish - There was a problem publishing your website. Please check that your …

Any Ideas??


(Douglas Cook) #2

Same problem. I tried to republish the site, previously about 1,300 files, now told there are nearly 8,000 and get the’Unable to publish’ message. Help!!!


(mik777) #3

After playing around with the settings myself, I went to Publishing, Mode and then changed the “passive mode” to the “extended passive mode” and although it took longer than normal my site did publish using the publish button. Thankfully :slight_smile:


(Brian LaPan) #4

You can always check our Knowledge base for answers, too!

http://kb.realmacsoftware.com/article/42-how-to-fix-ftp-publishing-issues


(Brian LaPan) #5

See the end of this topic: RW 7.0.2 (BETA) out of control with number of files


(afgrwg) #6

Yes, switch to extended passive mode. Quickly loaded site.


(Bjørn Arve Iversen) #7

Hi
I have a big site (veierlendingen.no) with a lot of pictures, a couple of blogs and more.

After utgrading to RW 7 I have big problems. The publish stops before publishing starts. During export.

If I choose only a few pages it works. Lets say I take 5 and 5 pages I can publish the hole site. I have run the «health check» and get a lot of errors which I do not think is real errors:
• Add Favicons and WebClip Icons
• Browser Title
• Add a description Metatag
• Improve Image Accessibility
• Improve Image Filename

It is 345 such «errors», so I will not start to fix it just to see how it works.

I have used an ftp-client to erase all old stuff.

I use «Extended Passive mode».

Any idea what to look for?

Best regars
Bjørn Arve


(Brandon Scott Corlett) #8

I had the same issue.

For me it was because RW7 defaults to exploring using 6 Connections.

My host really doesn’t like that and will block the upload from occurring.

I can get away with 3 if I’m not doing a lot of publishing, but if I’m continuously uploading changes while working I have to drop down to 1 or 2 so that they don’t suspend my ftp access.


(Scott) #9

same problem here, five weeks and other than being told to upgrade to beta versions of software that crash. Each beta has made the problem worse and now with latest .3 version doesn’t even export a single page… I thought RW6 was terrible but 7 has been worse for me as I now have a site I cant maintain.


(Bjørn Arve Iversen) #10

Hi
Problem solved for me. My host changed system in some way — then it worked.

Bjørn Arve


(Don Sinclair) #11

I upgraded to Sierra then to RW 7.1.7 for the FOURTH time today and for the FOURTH time will have to revert my entire machine back to El Capitan and use 7.0.4.

This is so damn disappointing and it has happened to me on EVERY SINGLE UPGRADE SINCE RW 5.

The issue? Change one single file to make a correction and RW uploads my entire site for the past two months with a 90 minute upload of over 1,000 files. GRRRRRRR!

When wil RW get it right and why is this an issue every damn time?

I guess my only alternative is to seek another software program that actually works.


(Brian LaPan) #12

@sinc, have you tried the latest beta?


(Don Sinclair) #13

Hello Brian,

Thanks for the suggestion. I downloaded 7.2 and then composed a new file for my website for today. I uploaded it and it showed 52 files went up.

I then noticed a bad link in a single line of type and had to change it. Changing three words and the hot link resulted in RW uploading 51 files (or 99%) of what it had uploaded five minutes earlier.

Same old, same old problem.

Thanks for trying,

Don