BUG in RW 7.2.2 & 7.2.1


(Ben) #1

It is impossible to save a project after adding an “offsite page”.
Rapidweaver crashes completely. (I tried on different projects, two computers and two different projects).
Does anyone have a solution?
Thanks in advance !


Spinning beach ball of death | 7.2x
(David) #2

That’s interesting. I was not able to publish or export an “offsite page” in RW 7.2.1. RW wouldn’t crash, but it just wouldn’t publish or export the “offsite page”.


(Ben) #3

strange. Here, Rw freezes whenever I want to save it. Even on an empty project with just an "offline page.
This is a very annoying bug.


(Robert Ziebol 🖖🏼) #4

I can confirm this bug, @bendeparis, have you sent in a bug report to Realmac??


(Robert Ziebol 🖖🏼) #5

What happens when you try to save??


(David) #6

The projects will save OK and everything else gets published or exported. Kind of strange.

I just tried publishing the PulseCMS demo project which has an “offsite page” for the Admin page and RW 7.2.1 had the same behavior - it published all the files except the Admin “offsite page”. I’m going to download 7.2.2 and see if that will publish the “offsite page”.

Here’s my original post about the problem:


(David) #7

The same thing happens with RW 7.2.2 - it just won’t publish the offsite page whether I try to publish just the page or “republish all files”.

It seems to skip the offsite page in the sheet displaying “preparing pages to publish” but after publishing marks the page as “published”.

It’s also a drag as I can’t “view source” for the offsite page - all i see is a blank page with only the number “1” for the first line of code, but that’s it - no other code or line numbers. So i can’t do my trick of copying the code to a text editor and uploading that as the offsite page. Hmmm… @dan any ideas?

EDIT: I also noticed that the Offsite Page is not listed in the sitemap.xml


(Butternut Squash) #8

This may indeed be some kind of bug, but it is not a universal bug.

I had responded to David @thang previously, that I was able to both save and successfully upload an Offsite file.

http://www.pomelopress.com/blogtest

I am running 7.2.1 on an iMac with OS 10.11.6.

FWIW.


(David) #9

I just read your post in the thread about the tumblr stack where you mentioned you were using the Offsite stack and it got me wondering if you’re using the Offsite page or the Offsite stack on a Stacks page. Thanks!


(Butternut Squash) #10

Offsite stack on a Stacks page.

Is that what you were having a problem with, or did I misunderstand?


(David) #11

Thanks for the clarification. @bendeparis and I are having problems wth the Offsite Page, which is a Plug-in that comes with RW. The Offsite stack is just that - a stack, so yes I think you did misunderstand, but glad it was clarified. :+1:


(Ben) #12

Rw freezes instantly. It is then impossible to quit RW.


(Doug Bennett) #13

David,
Might be a stupid question but do you have the option checked on you offsite page?


(David) #14

Hi Doug,

I don’t have the option checked. I will try that right now.


(David) #15

Thanks Doug - that worked! RW published the page and it’s folder. :grin:

I never was quite clear about that “Use Redirect Page” option, and since in the Demo for Pulse it was not checked, I hadn’t checked it either. The published page does seem to work as it should for the Pulse Admin page.

I think i’m missing something obvious about how the offsite page works as far as the “Use Redirect Page” option.

So what is the difference as to using the “Use Redirect Page” option or not. What situations should the option be checked for, and what situations should it be left unchecked?

Thanks!


(Doug Bennett) #16

My understanding of it (maybe wrong) is with it unchecked it just adds a link into navigation with the URL, but does not publish a page on your site.
Only reason I know this I was trying to help someone who was having a link problem, and Dan asked that question. There was a bug in one of the earlier RW7 releases were even if checked the page did not publish.


(David) #17

In RW6 without the option checked RW published the offsite page and folder. I had thought that not checking the option would have RW only publish the page and not the folder, but I was apparently wrong about that. Maybe that was something that was fixed in RW7 to have the checked/unchecked option work as you described.

Either way it’s great to have a solution - that was driving me nuts.

Thanks Doug!


(Dominick Designs Websites & Tech Training Seminars LLC) #18

Hello,

did you every find a solution for this? It’s happening to me. I have to force quit and basically can’t use an offisite page. It seems like RW is fragile and I need to be very careful when using it, otherwise it will hang and I need to force quit.


(Robert Ziebol 🖖🏼) #19

Has anyone reported this issue to Realmac???


(Ben) #20

Yes. I did it. No answer yet.