Can no longer publish now that I am using SSL


(Brad Miller) #1

I just added SSL to a site I have been building with RW 6.3.7. I am using @joeworkman Foundation theme and all of the plugins I use are up to date.

I made a few small changes to the site this morning with no problem. This afternoon, I added an SSL certificate to my website at tandemarriage.com. I have been unable to publish since adding the SSL certificate. Since I host at Chillidog Hosting, I contacted @barchard for help. He had me change the protocol from FTP to SFTP, the server from tandemmarriage.com to ftp.tandemmarriage.com:23261, and lower the number of consecutive connections that RW can make to 2.

After doing all of this, I still get an error message when trying to publish. Greg suggested that his may be a RW bug and told me to contact you.

Please help. Thanks.

Lastly, I sent an email to support@realmacsoftware.com over 24 hours ago and have heard nothing back. What’s up with that?
I’m dying here since I was trying to update the site for a Valentine’s Day contest starting February 1st.


(Joe Workman) #2

Does the folder that you are trying to publish to actually exist?


(Brad Miller) #3

Yes, it does. I just pulled it up in my FTP app to be sure.


(EricW) #4

First thing you could to is publish the site to disk (“export” in menu), and use a (s)ftp program like Cyberduck (free) to move it to your provider. This way you circumvent the publishing-engine from Rapidweaver and have a workaround if you don’t want to rollback your SSL implementation.


(Brad Miller) #5

This worked @EricW.
Don’t you just hate it when someone like @EricW suggests something that you know your should have thought of? But seriously, thank you.

Still no word from the normally responsive and helpful folks over at Realmac. Maybe @dan and @ben are on holiday.


(Nik Fletcher) #6

@firedude2894 Just replied to your message now. Sorry for the delay in getting back to you!

—N


(Brad Miller) #7

Honestly, I have never received such a slow response to a RW issue. I hope you are all doing ok. What’s going on?
I feel like the kid in school who forgot to put deodorant on. :flushed:


(Nik Fletcher) #8

Hi Brad

For the more advanced issues, they get referred to me. I’m working through my assignments at the moment (alongside everything else ;)). Sorry for the delay, will be in touch ASAP!


(Brad Miller) #9

For anyone reading this post and wondering about the outcome:
Removing the slash “/” in the beginning of the path name (see first screenshot) did the trick. Apparently, some servers already add “/” to the path name which results in RW looking for a path that starts with two slashes.
Thanks Nik.


(Nik Fletcher) #10

My pleasure! Sorry for the delay in getting this sorted.