Cannot uninstall stacks

I am still having spinning ball issue with my RW and I noticed that when RW first loads, it loading the stacks but there would be a long pause at 98% on the stack loading bar before it completes.

I thought many I have too many stacks so I would go uninstall all unused ones or ones I no longer use.

Opened library and right click on a stack and select uninstall in menu … nothing happens … stack still in there…

What am I doing wrong?

Thank you

I doubt it’s to many stacks causing the issue. I’ve seen that freezing at 98% before and usually if I click on another page the message goes away.

As for uninstalling, did you restart RapidWeaver?

I restarted it and it went away but the template did not.

Even the files are gone however it showing list of templates in numbers instead of names in the library. When I drag a template to RW editor box … I don’t recall those templates before .

I did a “Show in Finder” and those template is no where to be found in the stack folder or template folder.

Also, you are right reducing the number of stacks did not help the lagging or prevent spinning beach ball when scrolling.

Maybe I narrowed it down some more …

This templates is not showing up when I create a new project or open other project files … Just that one project and the templates are not even mine …

I think it came from someone who sent me their project file to have me look at it but why is it showing up in some of my project files???

But not in all of it

I managed to finally remove those templates by uninstalling it then save the project file that it opened from and restart the RW.

But still spinning beach ball :confused:

i did a bunch of work on this beach ball today Bill. (edit: we did a bunch of work – i worked with Joe to come up with a solution for this – it took both of us working all day to uncover the problem and come up with possible solutions)

i think some updates coming out shortly (both to Stacks and Foundation) might significantly improve performance of pages like this one (it’s unique because it’s a very long partial with lots and lots of little items inside), especially on machines with limited video memory.

believe it or not, it all came down to the color of one of the borders of the default objects.

i know how unlikely that sounds – but compositing layers together turns out to be very costly – it eats up a lot of video memory. compositing all the little partially see-through borders of all those little cells inside the partial ate up all your video memory. simply switching to an color that’s not partially see-through means no more compositing – and no hit to the video card.

this will come first as a Foundation 6 update that i think Joe may have already sent out – since you’re using Foundation 6 you’ll benefit from those changes immediately.

later i’ll incorporate similar changes that will correct this all users and all files.
thanks for sending your files. that’s what enabled us to fix this one. :slight_smile:

oh… and please let us know if this helps. there is the possibility that even this change will not be enough and we need to get even more drastic by paring down styles so they work on all Macs.


1 Like


Awesome! Thank you for looking into it and you’re the best!

don’t thank me until after you verify it’s fixed. :joy:

but seriously, i think these couple things will at least improve things. but let us know how it turns out after installing that Foundation update.

I updated F6 just now on my MacBook Pro and it’s smooth with no spinning beach ball!

I will have to wait tomorrow at work to update on the IMac Desktop where it had the worse spinning beach ball before I can verify it. I will post the result here first thing in the morning when I get to work.

Thanks again!


I am at work and just updated on my work iMac …

No spinning beach ball after the F6 updates … Many Thanks to @isaiah and @joeworkman both you are the best!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.