Cannot upload changes


(Alan Page) #1

I have two Rapidweaver sites, hosted by the same company. Recently, one of my sites has been playing up when I try to upload new material, with error message “Couldn’t sign in to your FTP server, failure when receiving data from the peer.” I’ve needed to have a couple of tries to get it to upload. But today, no matter how many tries, I keep getting the same error message and cannot complete the task. I have checked with the Web Host, and everything is ok at their end. Help. I need to keep my website fresh.


(Greg Schneck) #2

To verify settings and such… Can you connect with an ftp/sftp app? You could also export to local folder and upload with ftp until you figure out the RW issue.


(Alan Page) #3

I am non-tech. I don’t think I have an ftp app, but I’ll see what I can find out. Thanks for your prompt response.


(Greg Schneck) #4

If you are going to have a website you really should know how to use an ftp/sftp app. Very useful for viewing what is going on with your site (actual life files on the server) as far as file/folder structure etc. In fact, I learned a great deal of how RW “operates” just but publishing (exporting) to a local folder, checking things out, and then uploading. You also need to use ftp to delete old unwanted files, test files, etc which may get “lost” on your server. (RW does not delete server files if you delete a page from your project).

I use Yummy FTP but it’s a paid app. There a many free ones. Cyberduck, FileZilla, Transmit, etc…


(Alan Page) #5

Thanks. I’ve had my sites for over four years without problem until now. I will get an ftp app.


(Greg Schneck) #6

FTP app is simply another tool in the toolbox. To help debug connections and upload if you can’t cannot from RW. Also, if you have a large site I find that, usually, FTP apps will upload your site a lot faster.

But you do need to get your RW connection working. What happens when you use the “Test” button from the RW Publish Setup pane?


(Isaiah Carew) #7

95% of all ftp problems come down to a password issue.

either the host had its password reset
or the user’s password storage app stopped working well
or the user simply mistyped it

whenever there is an ftp problem it will save time to first triple check that you are positive you are sure you’re not amongst the 95%

  • clear and re-enter your password into RapidWeaver
  • sign in to you hosting company and reset your ftp password (if possible)
  • use another ftp app (there are a few free ones on the app store) to verify all is working correctly

once you’re sure that your password is working well, your host is accepting it, and it’s entered correctly in RapidWeaver then the next step would be to look more closely at the error messages that are being displayed.


(Alan Page) #8

It wasn’t a password issue. I checked that. I also had it checked by the Web Host. Anyway, whilst doing other things, I kept trying to load up. Eventually, at the umpteenth attempt – success. Very strange. I’ve sent information to RapidWeaver and I will get myself an FTP app. Thanks for the advice, guys.


(Mathew Mitchell) #9

@alpage The FTP portion of RW has gotten better with each new iteration of RapidWeaver. But that FTP functionality is still not as “robust” as a dedicated FTP app. I rarely have problems publishing with RW 7, but once in a long while I’ll run into a problem. Typically there’s something else going on at the same time: specifically my home or office internet bandwidth has been reduced by a noticeable amount. Other users? Perhaps. Moon in retrograde? Unlikely. :slight_smile:

… so when my internet at home is super slow I simply restart the router. Then RW publishing will also go much smoother. May not apply to your case … but it’s definitely possible for you to have everything set up correctly and the publishing still not work at times. At those same moments my FTP app of choice (Transmit) still works perfectly fine.

My guess is version 8 will improve publishing reliability again. But RW may never equal a dedicated FTP app, so it’s always good to choose one and learn how to use it.


(Alan Page) #10

Once again, thanks for the advice.


(LJ) #11

Have you checked the publishing modes in Publishing settings? by default ‘Extended Passive’ but you might want to try the others and see what happens.

Also - you do have enough space allocated on the server I assume? Would be strange not to as most RW projects are not that big but you never know!

Finally - I have occasionally experienced an issue where the password needed to be reset on the server. No idea what causes this - maybe some security issue - but I can think of half a dozen occasions when simply resetting the password - either the same or different - has done the trick when ftp fails.


(Alan Page) #12

All very good points. LJ, and I did as you suggest at the time: the publishing settings, password and situation with the server. Subsequently, for no apparent reason, I was able to upload. Then, later, when I tried again, the problem reoccured. But I tried this morning and it worked at the second attempt. Yummy FTP Pro has been downloaded and I will start to study it when I have time. Thanks.