New update Rapidweaver 8.1.4 blocks upload to ftp-server


(Filip Loobuyck) #1

Hi, I have an issue with Rapidweaver 8.1.4.
Since the update from 8.1.3 to 8.1.4 I can’t upload the changes in my website to my ftp-server.
I contacted the server company “one.com” to look into this issue, but after inspection
it has nothing to do with eventually server-problems.
Do anyone knows how to solve this problem?
Thanks, Filip


8.1.4 crashes Rapidweaver
(Doug Bennett) #2

Hi Filip,

I think a bit more information would help you get help with your issue.

What exactly is happening when you try to publish? You said “blocks” in the title of the post, is that part of the message? Perhaps a screenshot of what’s happening when you publish would help. Have you tried the test button in the publishing settings? A screenshot of your publishing settings might help as well.


(Filip Loobuyck) #3

Hi Doug,

yes correct, you can find 2 screenshots here under.
In the publishing settings I have used the test button and the respons is “Connection Test Successful”
The exact description of the problem is that the publishing tries and tries and tries, but never succeeds.
( see screenshot )
Hope this helps.


(Filip Loobuyck) #4

Here is the screenshot of the publishing settings


(Guy Woodland) #5

Two thoughts, maybe change the connection setting to see if that makes a difference. Why is the path /NL rather than /


(Scott Frankel) #6

Hi
I had similar issue with RW 8.0.3 and changed the connection speed from “6 - lightning fast” to the “1 - slowest” most compatible.
Seems to happen when internet speed is slow, I had issue when staying at airbnb place with slow internet speeds. Changed to “1 - slowest” and that seemed to upload better.


(Filip Loobuyck) #7

Hi Scott,
thanks for the suggestion. I tried that, but no difference.


(Jan Fuellemann) #8

What happen when you delete the / before NL?


(Mathew Mitchell) #9

You are also doing lightening fast. Pull it down a bit to a slower speed.


(Filip Loobuyck) #10

Hi Jan,
the site has 4 languages, so it need to be uploaded to the wright language. In this case Dutch.
So /NL for dutch, /EN for English and so on.


(Kevin Atkins) #11

I feel your pain Filip. I can now no longer publish any of my RW sites to one server. Initially, it was just a single site, but now all sites on the same server are affected.

I’m in contact with Support, but they’ve not managed to fix it, and only mention a potential permissions issue on my Mac (and, no, repairing permissions didn’t help). The hosts have checked the server, and there are no issues that they ca find. More tellingly perhaps, other FTP apps (Cyberduck and Dreamweaver) connect fine, and can upload. I don’t backup to the server, though, which you appear to do.

Not that I could, even if I wanted to.

One annoying issue is that RW does connect, and can navigate to choose a directory, but it refuse to upload, with the same error you are seeing. While this - currently - only affects one of the servers I upload to, the issue has gotten so bad at my place of work (and worse over the last week), that I’m advising not to use Rapidweaver, and to look into migrating from RW to something more reliable, or with better FTP features.


(Filip Loobuyck) #12

Hi Kevin,
thanks for your reaction. Ok so I am not alone having this problem.
Is it possible to upload a Rapidweaver project with another FTP app, like Transmit or Filezilla ?
My site is for my job , so it is really important not to stay with this issue and find a solution as soon as possible.


(Kevin Atkins) #13

Yes it is. It’s a pain, and shouldn’t be required for an app that purports to have its own built-in capability, but hey-ho!

I use Cyberduck, but any should work. You’ll need to make a new bookmark and select Local Folder as the destination (you get a choice of where, of course). Use the Publish button (top-right on your project), but select the arrow, and choose your new bookmark, not your existing FTP bookmark. You should then be able to upload the content of that local folder using the FTP app.

The only complication I have found is for ‘invisible’ files: those with a period at the start, such as .htaccess. Most FTP clients will show these (although it may be toggled on/off, depending on app), but you can’t see them (without a workaround) in OS X. If you’ve not made such a file, it shouldn’t be an issue.

Hope that helps Filip.


(Filip Loobuyck) #14

Hi Kevin,

thanks.
I also found out that in Rapidweaver it is possible to choose File -> Export Site to a local folder on the Mac-computer. It has the same result.
I contacted Realmac 2 days ago to ask for a solution to this problem and until now I didn’t have any reaction at all. ?? Very strange.


(Doug Bennett) #15

That’s a clue.
Has nothing to do with your hosting company, publishing credentials or connection speed.

You said “It has the same result.”. Did you get the exact same result when exporting to a folder?


(Kevin Atkins) #16

Hmm … Teefers could be onto something: you shouldn’t see FTP mentioned if you’re only publishing to a local folder. Ensure you haven’t also attempted to publish to FTP. I use the pulldown if there are more than one publishing bookmarks associated with a site. The example below shows the FTP (H&H) and the local (DGG Local):

46


(Kevin Atkins) #17

Of course, you could also use Export, from the File menu!


(David Freels) #18

What OS X are you using? Everybody, can we determine if the base OS X is no longer supported? Is this the root cause of all these issues?


(Kevin Atkins) #19

10.14.3, but this issue first appeared on 10.14.2 for me.


(Wayne Olson) #20

Just want to add I am having the exact same problem. Here’s one thing I did, that may help diagnose it, although it does not fix it.

  1. I was having trouble uploading my site.
  2. I copied its parts to a brand new file. Essentially, starting from scratch.
  3. As I worked on it and in Rapidweaver, I uploaded it several times. WORKED FINE.
  4. I exited Rapidweaver and went to lunch.
  5. When I came back, opened Rapidweaver, and tried uploading again - I got the “Can’t upload to FTP server” error.
    I changed nothing in any of the settings. What worked in the initial setting, failed after closing and re-opening Rapidweaver. If anyone is listening who can identify what this means, we may have a solution. Rapidweaver does something on start-up that modifies some internal setting.
    I too, have contacted support for about a month, but with no resolution. I am about to drop Rapidweaver, and stop recommending it to all those who I have been recommending. My business is suffering severely because of this, and I cannot afford to keep hurting it.
    Wayne O.