Cannot upload RW project to FTP server due to "Timeout was reached'

Hi there,
I cannot upload my RW project to our FTP server due to "Timeout was reached’… (see attached screenshot).
This drives me crazy, especially since some important business partners have to visit my website right now. In other words, a disaster !


Also, when clicking onto the internal Preview, all screen turns black and it takes quite a while before it shows up.
Strange enough, I can upload another RW Project right onto the same server without any problems whatsoever…
Can somebody please advice what’s going on and what to do about this?
Thank you very much.

I had this happening to me once, I went to my account deleted all files, and tried again, and the same thing happened, i then exported the site and uploaded it with Cyberduck and everything went fine, and any updates of pages after that went fine with RW ftp; so i do not know where the problem was coming from but it was solved in a few minutes

Hi,
that is exactly what I did. Files are on and work but I cannot make any changes and upload them without exporting them and manually throwing them onto Cyberduck…
Impossible to work like this on the long run.

Hi @hucky,

It could be that your host doesn’t allow opening a lot of connections simultaneously (like RapidWeaver does).

You can test this by selecting a lower speed:

  1. Open your project file in RapidWeaver and go to the Publishing settings
  2. Set Connections to the lowest possible speed:
  3. Try to re-publish all files and see if hte problem goes away
  4. Repeat the above, but set the Connections to the next higher up speed setting. Do this again for the next higher up one until the problem reappears.

If this (selecting a lower connections speed) solves the issue, the problem is that your host only allows a certain amount of simultaneous connections to their server. You can leave RapidWeaver at the setting that works, or contact your host to request more simultaneous connections if you really need it.

If setting RapidWeaver to the lowest possible connection speed doesn’t work, it’s something else.

Cheers,
Erwin

1 Like

Thank you, Erwin,
I tried it all but unfortunately to no avail. What is strange is that I can still upload another file without any problems. I can also save the project and then throw it onto Cyberduck FTP Client and it all works but that is of course, no solution to work on.
Cheers

Hi Erwin,

The people at our server ask if
'RW (or Cyberduck?) has a TimeOut settings to disable the cancellation?
In FileZilla, you can disable this, for example.’

Interesting question which I cannot answer
Cheers
Hucky

Hi @hucky,

Unfortunately, RapidWeaver doesn’t allow you to change the timeout settings.

@dang am I missing something?

Cheers,
Erwin

Thank you for finding out, Erwin.
After fiddling around i.e. removing and reloading everything I finally managed to get it up bit by bit…
What an experience… hope it won’t happen again
Thank you